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1. About this manual

1.1 Software versions

The information in this document corresponds to the following software versions.

Software Details Version

BSP/OS 

AMC 300 Board Support Package PCM3.1 BSPv4 (4.0.5.0) or later
PCM3.3 BSPv4 (5.0.0.0) or later

AWC 500 Operating System PCM5.2 OSv3 (3.0.1.0) or later 

AMC 600 Operating System PCM6.1 OSv3 (1.0.1.0) or later 

iE 250 PLC Operating System BSPv5 (5.0.0.0) or later 

CODESYS CONTROL CODESYS run-time V3.5 SP 15 3.5.15.20
V3.5 SP 18 3.5.18.40 or later

CODESYS IDE PC software for development of CODESYS applications V3.5 SP 15 3.5.15.20
V3.5 SP 18 3.5.18.40 or later

CODESYS TSP 

AMC 300 CODESYS Target Support Package (TSP)
AWC 500 CODESYS Target Support Package (TSP)
AMC 600 CODESYS Target Support Package (TSP)
iE 250 PLC CODESYS Target Support Package (TSP)

1.3.0.7 or later 

1.2 Technical support

CODESYS in general

The CODESYS store 
My question: Ask questions about CODESYS.
FAQ: Frequently asked questions.
Forum: Discuss different CODESYS topics with other users.

CODESYS Development System
online help Online help is available from the Help menu. 

DEIF support options

Technical documentation Download all technical product documentation from https://www.deif.com/
documentation.

Support 

DEIF offers 24-hour support.
See www.deif.com for contact details, there may be a DEIF subsidiary located near
you.
You can also e-mail support@deif.com.

Service DEIF engineers can help with design, commissioning, operating and optimisation. 

Training DEIF regularly offers training courses at the DEIF offices worldwide. 

1.3 System requirements

The requirements for the development PC to install the Development packages, PC tools and drivers are:
• Microsoft Windows 10, 32 bit version
• Microsoft Windows 10, 64 bit version (Recommended)

As the AMC 300 and the AMC 600 support SSH (Secure Shell) and SCP (Secure Copy) as basic communication protocols, it
can be accessed from any system supporting these protocols (if enabled).
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NOTE Not all browsers are suitable for this software. We recommend to use Google Chrome or Mozilla Firefox.

1.4 Warnings and safety

Recommendations for data security

To minimise the risk of data security breaches we recommend to:
• As far as possible, avoid exposing controllers and controller networks to public networks and the Internet.
• Use additional security layers like a VPN for remote access, and install firewall mechanisms.
• Restrict access to authorised persons.

1.5 Legal information

Disclaimer

DEIF A/S reserves the right to change any of the contents of this document without prior notice.

The English version of this document always contains the most recent and up-to-date information about the product. DEIF
does not take responsibility for the accuracy of translations, and translations might not be updated at the same time as the
English document. If there is a discrepancy, the English version prevails.

Trademarks

DEIF is a trademark of DEIF A/S.

CODESYS® is a trademark of CODESYS GmbH.

All trademarks are the properties of their respective owners.

Copyright

© Copyright DEIF A/S. All rights reserved.
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2. Installation

2.1 CODESYS development package

2.1.1 About the CODESYS development package

The AMC 300, AMC 600, AWC 500, and iE 250 PLC CODESYS development packages consist of three parts:
• CODESYS IDE: Installed on the development PC.
• CODESYS TSP (targeting AMC 300, AMC 600, AWC 500, or iE 250 PLC): Target support package installed into the IDE.
• CODESYS CONTROL run-time: Runs on the controller hardware.

CODESYS CONTROL run-time
The installation process for the CODESYS CONTROL run-time depends on the BSP/OS version.

For:
• AMC 300 PCM3.1 (BSPv4)
• AMC 300 PCM3.3 (BSPv5)
• AMC 600 PCM6.2 (BSPv5)
• iE 250 PLC PCM2.1 (BSPv5)

the CODESYS CONTROL run-time is bundled in the operating system. An update of the PLC run-time follows the update of
a new bundle.

Whereas for:
• AWC 500 PCM5.2
• AMC 600 PCM6.1 (OSv3)

the CODESYS CONTROL run-time is added via the installation package (.dupdate file). This package is pre-installed from
the DEIF factory when you order the controller. You can update the CODESYS CONTROL run-time independently from the
operating system.

2.1.2 Download the CODESYS development package

You can download the CODESYS IDE, CODESYS TSP, and the CODESYS run-time by submitting your email address via the
DEIF website. A link is sent to you to download the CODESYS IDE and CODESYS TSP, respectively.

Follow these steps to download the CODESYS IDE:
1. Go to the DEIF website www.deif.com.

2. Open the search bar , and type the controller name to open a list of product options.
3. Select the controller from the list.
4. Select the Software tab.
5. Open the CODESYS list, and select either:

• AMC 300 CODESYS TSP v1.3.0.x
• AWC 500 CODESYS TSP v1.3.0.x
• AMC 600 CODESYS TSP v1.3.0.x or
• iE 250 PLC CODESYS TSP v1.3.0.x

6. Submit your email address to receive a download link to the software.
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someone@someone.com

E-mail notification on future releases

Download

7. Follow the link in the email to download the DEIF CODESYS software package to your computer.
8. Repeat the steps to download the CODESYS IDE installation file, for example:

• CODESYS V3.5 SP15 or
• CODESYS V3.5 SP18

9. If it is necessary to update the CODESYS run-time, download the CODESYS CONTROL run-time. For example,
• AMC 300 PCM3.1 Code package
• AWC 500 CODESYS run-time for PCM5.2
• AMC 600 CODESYS run-time for PCM6.1 or
• iE 250, AMC 300, or AMC 600 Code package (common for PCM2.1, PCM3.3 and PCM6.2)
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2.2 Install CODESYS V3.5 SP15

This section guides you through the installation of the CODESYS IDE and installation of the CODESYS TSP.

1. Run the installation file (for example, CODESYS 64 3.5.15.20.exe) to install CODESYS IDE to the development computer
with default settings.

2. If you are prompted to install necessary Microsoft Visual C++ packages, follow the instructions on the screen.

The CODESYS InstallShield Wizard
1. When the CODESYS InstallShield Wizard starts, select Next.

2. Licence Agreement: Accept the agreement and select Next.
3. Choose Destination Location: Choose a folder for the installation, and select Next.
4. Select Features: Choose the features you want to install, and select Next.
5. Select Program Folder: Choose a program folder, and select Next.
6. Start Copying Files: The chosen features and the destination folder are shown. If everything is correct, select Next.
7. Very important information: Confirm that you have read the information, and select Next.
8. InstallShield Wizard Complete: Select Finish to exit the installation wizard.

2.2.1 Install the CODESYS TSP

1. Run the installation file (for example, pcm6.1-amc600-codesys-3.5.15.20-geb5a1b.package) to install the AMC 600
CODESYS TSP (Target Support Package) to the development computer with default settings.
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2. The file extension .package is registered with CODESYS on Windows. If CODESYS is not installed or you do not have the
correct version, you will see this message:

3. Install a correct version of CODESYS (see section Install CODESYS V3.5 SP15), then run the installation file again.

If CODESYS is installed, but you do not want the AMC 600 CODESYS TSP package associated with it, you can open
CODESYS and install the package file with Open > Install package.

This starts the Package Manager and installs the required AMC 600 Device Descriptions (and the EtherCAT Slave
Information files).

1. Choose a setup, and select Next.

2. When the package is installed, select Next to finish the installation.
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3. Select Finish to exit the installation wizard or Next to see a summary.

2.2.2 Open CODESYS for the first time

To open CODESYS you can:
• Double-click the desktop icon

• In the start menu, select Start > 3S CODESYS > CODESYS V3.5 SP15 (or later version)

The CODESYS start page:
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2.3 Install CODESYS V3.5 SP18

This section guides you through the installation of the CODESYS IDE and installation of the CODESYS TSP.

From CODESYS V3.5 SP18, you have the option to use the direct installation or install CODESYS via the CODESYS Installer.
Both methods are shown in this section.

1. Run the installation file (for example, CODESYS 64 3.5.18.30.exe) to install CODESYS IDE to the development computer
with default settings.

2. If you are prompted to install necessary Microsoft Visual C++ packages, follow the instructions on the screen.

The CODESYS InstallShield Wizard
1. When the CODESYS InstallShield Wizard starts, select Next.

2. Licence Agreement: Accept the agreement and select Next.
3. Choose Destination Location: Choose a folder for the installation, and select Next.
4. Select Features: Choose the features you want to install, and select Next.
5. Select Program Folder: Choose a program folder, and select Next.
6. Start Copying Files: The chosen features and the destination folder are shown. If everything is correct, select Next.
7. Very important information: Confirm that you have read the information, and select Next.
8. InstallShield Wizard Complete: Select Finish to exit the installation wizard.

2.3.1 Install the CODESYS TSP

1. Run the installation file (for example, pcm6.1-amc600-codesys-3.5.18.30-tsp-v1.3.0.6-52-g11407312) to install the AMC
600 CODESYS TSP (Target Support Package) to the development computer with default settings.
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2. The file extension .package is registered with CODESYS on Windows. If CODESYS is not installed or it is not a correct
version, you will see this message.

3. Install a correct version of CODESYS (see section Install CODESYS V3.5 SP18), then run the installation file again.

If CODESYS is installed, but you do not want the CODESYS TSP package associated with it, you can open CODESYS and
install the package file via Open > Install package. This starts the Package Manager and installs the required EtherCAT
Device Descriptions for the controller products (and the EtherCAT Slave Information files)

4. When the installation starts, select the CODESYS version for installation.

5. Select that you want to Continue although there is a missing installation package.
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6. Select OK when the installation has been completed.

You can view the installed CODESYS TSP in the CODESYS Installer, as shown below.

7. Choose a setup, and select Next.
8. When the package is installed, select Next to finish the installation.
9. Select Finish to exit the installation wizard, or Next to see a summary.

2.3.2 Install/upgrade CODESYS V3 installation via CODESYS Installer

The CODESYS Installer is a Package Manager that can be used to manage CODESYS Installations.

1. Run the installation file for CODESYS Installer (for example, CODESYS Installer 1.5.0.exe) to install the CODESYS Installer
to the development computer with default settings.
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2. If you are prompted to install necessary Microsoft Visual C++ packages, follow the instructions on the screen.

The CODESYS Installer InstallShield Wizard
1. When the CODESYS InstallShield Wizard starts, select Next.

2. Licence Agreement: Accept the agreement, and select Next.
3. InstallShield Wizard Complete: Select Launch CODESYS Installer and Finish to exit the installation.

Add new CODESYS Installation
1. Open CODESYS Installer, and select New Installation in the upper right corner.

2. Select the new CODESYS version to install and the previous version to import settings from.
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2.3.3 Open CODESYS for the first time

To open CODESYS you can:
• Double-click the desktop icon

• In the start menu, select Start > 3S CODESYS > CODESYS V3.5 SP18 (or later version)

The CODESYS start page:
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3. CODESYS Online Help

3.1 Start the CODESYS Online Help

Use the CODESYS Online Help to get more detailed information about the CODESYS programming environment.

On the CODESYS start page, select Help > Contents in the menu.

This opens the CODESYS Online Help page.
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3.2 New to CODESYS

If you are new to CODESYS, we recommend you start with the guide under the menu Your First CODESYS Program.

3.3 Visualization

Under the menu CODESYS Visualization, you can read more about the possibilities with visualization.
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3.4 Programming references

Detailed information about programming is found under the menu Reference, Programming.

3.5 Libraries included in CODESYS

The standard libraries are described under the menu Libraries.

More information about libraries is found in the Library Manager for DEIF specific libraries.
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3.6 Language settings

The default language for the menu and help files is English. You can change this under Tool > Options > International
Settings to a variety of languages.

NOTE The CODESYS TSP must be installed before you change the language settings.
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4. Create a CODESYS project

4.1 Create a new project

To create a new CODESYS project:
1. Go to File > New Project *.

2. Select Standard project in the Templates field.
3. Write a project name.
4. Select a location path for the project file.
5. Select OK to open the Standard Project window.

6. In the Device field, select one of these as the device:
• AMC 300 PCM 3.1 (DEIF A/S)
• AWC 500 PCM 5.2 (DEIF A/S)
• AMC 600 PCM 6.1 (DEIF A/S) or
• iE 250 PCM2.1 (DEIF A/S)

7. In the PLC_PRG in field, select Structured Text (ST) as the programming language. **
8. Select OK to continue.

NOTE * You can also select Empty project if you want to create an entire project from scratch.
NOTE ** New POUs can use a different programming language.
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4.2 CODESYS layout

The image below shows the terminology used for the project view throughout the CODESYS manual.

No. Item Description

1 Project tree 

The project tree is an overview of your project.
A typical project will consist of:
• One or more devices (AMC 300, AWC 500, AMC 600, or iE 250 PLC controllers).
• One or more applications containing the Libraries, POUs and tasks.

2 PLC Logic node A PLC Logic node shows that the device is a programmable device and has no other
functions associated to it. 

3 Library manager 
The Library manager contains the libraries for the project.
Each library consists of functions and function blocks that can be used in your
programs.

4 Devices tab The Devices tab gives you quick access to the project tree. 

5 POUs tab The POUs (Program Object Units) tab gives you quick access to the device
independent POUs. 

6 Working area 

The working area consists of tabs representing different parts of the project. These
project parts can be opened from the project tree.
The illustration shows the working area for the POU, PLC_PRG. The working area for
this POU consists of a declaration workspace, an implementation workspace and a
toolbox menu.

7 Declaration workspace The declaration workspace consists of the variables for the POU functions.

8 Additional toolboxes Some elements have additional toolboxes to help you build your program, for example
Visualisation. 

9 Implementation workspace The implementation workspace is used to program your POU. 
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4.3 Build from an empty project

1. Select File > New Project > Empty project.

2. Write a project name in the field Name (for example, Project1).
3. Select a location to save the project (for example, C:\Workspace\MyProject\).
4. Select OK to continue.

4.4 Add the DEIF Device

1. In the project window, select Add Device.

2. In the Add Device window, select a device from the list.
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3. Select Add Device.

4.5 Add EtherCAT master device

1. In the project window, select Add Device.

2. In the Add Device window, select a device from the list.
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3. Select Add Device.
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4.6 Connect to the AMC 300, AWC 500, AMC 600, or iE 250 PLC controller

1. In the project window, double-click the AMC 300, AWC 500, AMC 600, or iE 250 PLC controller.
• A gateway with the default IP address localhost is shown.
• We recommend you create a new gateway with a new IP address or hostname for the controller.

2. Select Gateway > Add new gateway.

3. Enter the hostname or the IP address for AMC 300, AWC 500, AMC 600, or iE 250 PLC controller (for example,
192.168.20.13).

4. Select OK.
5. Select Scan Network to find the PLC controller on the network.
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6. Select the device.
7. Select OK.
8. Select Device.
9. Select the device to set the active network path to the controller.

10. Select OK.
11. The connection is now active.
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4.7 Setup EtherCAT master

1. Open the EtherCAT_Master tag.

2. Change the NIC Settings to Select network by name.
3. Select Browse to find the network interface to bind the EtherCAT master to.
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4. Select:
• AMC 300: eth0 adapter* (corresponding to EtherCAT OUT port 1 and EtherCAT OUT port 2)
• AWC 500: ecat0 adapter*
• AMC 600: ecat0 adapter*

NOTE *The same network adapter number for the eth0 (EtherCAT port) is used on all shipped devices.

We recommend to specify which task handles the bus communication:
• In Device > PLC Settings > Bus cycle options: Specify the Bus cycle task to EtherCAT_master.

4.8 Scan for devices

1. Login to the PLC.
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2. In the pop-up window, select Yes to create an application.

3. Select EtherCAT_Master (EtherCAT_Master), and then Scan For Devices... in the drop-down menu.

NOTE If EtherCAT Master is running on the PLC, you can scan for devices without being logged in. If a scan
fails, then use the above procedure.

4. In the devices window, select Copy All Devices to Project.
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NOTE Due to a bug in CODESYS TSP, select the devices and Copy to project. Then add the SIM6.2 manually
under PCM6.1.

5. The devices are now displayed in the Devices tree.
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6. If the project is downloaded again, the entire EtherCAT network can enter operation.
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4.9 I/O module variables

In this section, an overview of the IO mapper of each module for the different controllers is shown.

4.9.1 AMC 300

IOM3‧1 variables
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IOM3‧2 variables

IOM3‧3 variables
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IOM3‧4 variables

ACM3‧1 variables
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PSM3⋅1 variables

PSM3⋅2 variables
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4.9.2 AMC 600

DIO6‧1 variables

AIO6‧1 variables
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TIM6‧1 variables

IFM6‧1 variables
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IFM6‧2 variables

4.10 Add a program

1. Select Application > Add Object > POU....

2. In the Add POU window, tick Program and select Add.
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4.11 Write a program

Example of a program.
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4.11.1 Add a task

1. Select Task configuration > Add Object > Task....

2. In the Add Task window, write a Task name and select Add.

3. Select the Add Call tab.
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4. In the Input Assistant window, select the program PLC_PRG.

5. The program PLC_PRG is now added to the project.

User manual 4189341353A UK Page 41 of 59



6. Login to the PLC.

4.11.2 Simulation mode

It is possible to use Simulation mode, if a PLC controller is not connected.
1. Select Simulation mode with Online > Simulation.
2. Login to the AMC 300 with Online > Login.
3. In the pop-up window, select Yes to create the program.

4. Select Debug > Start to run the program.
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4.11.3 Login to the PLC

Select Online > Login.

4.11.4 Start the program

To start the program, select Debug > Start.

The project is now running.

User manual 4189341353A UK Page 43 of 59



4.12 Link I/O variables to physical I/O

1. Select Online > Logout to go to offline mode.
2. Select a physical I/O.

3. Select … of F2 to edit.
4. In the Input Assistant window, select a variable.
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5. Select OK to link the variable to the physical I/O.

6. Repeat steps 1 to 5 for all output variables.
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4.13 Add visualization

1. Select Application > Add Object > Visualization.

2. In the Add Visualization window, activate the VisuSymbols (System) library.
3. Select Add.

4.13.1 Drawing visualization (example)

1. Draw an ellipse in the Visualization field.
2. Select Properties > Color variation > Toggle Color to link the ellipse to a variable.
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3. Set Properties > Colors > Alarmstate > Frame color to Black.
4. Set Properties > Colors > Alarmstate > Fill color to Grey.
5. Repeat steps 1 to 4 (or copy-paste the ellipse) 3 times.

6. Use Toggle Color to change the new variables to other outputs.
7. Add a counter field (rectangle).
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4.13.2 Set main visualization

1. Select the WebVisualization tab.

2. In the Input Assistant window, select Visualization.
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3. Select OK.
4. Login and run the program.
5. Select Visualization to view the first page.

4.13.3 View webvisualization or remote visualization

To see the webvisualization go to either
• http://[hostname or ip]:8080/webvisu.htm (for example, http://amc600.local:8080/webvisu.htm)
• via secure http to https://[hostname or ip]:8443/webvisu.htm (for example, http://amc600.local:8443/)
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NOTE The port for http may be 8000 in some software versions.
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4.14 Create a boot project

To make the PLC start with the application at power up, you can create a boot project in CODESYS.
1. Login to the PLC via Online > Login.
2. Select Online > Create boot application.

3. The boot project files are created under:
• /app/codesysapp/PlcLogic/Application
• /app/codesysapp/PlcLogic/visu

4. Reboot the PLC.

Remove a boot project
1. Login to the PLC via Online > Login.
2. Select Online > Reset origin.

3. Or you can remove boot project and clean all the application files in:
• /app/codesysapp/PlcLogic/Application and
• /app/codesysapp/PlcLogic/visu folders.

User manual 4189341353A UK Page 51 of 59



4.15 Manually force digital outputs for system testing

To manually force the digital outputs, for example for system testing, you must create a new empty project (see section
Create a new project).
1. Scan for devices.
2. Add devices.
3. Select PCM6_1 > PLC Settings.
4. Tick the box Update IO while in stop.
5. In the Always update variables drop-down list, select Enable 1 (use bus cycle task if not used in any task).

6. In the Bus cycle task drop-down list, select EtherCAT_Task.
7. Select PCM6_1 > Application [run].
8. Under a module tab, select EtherCAT I/O Mapping to see the values of all inputs.
9. Double-click Prepared value for the value you want to change.

10. Select F7 to force the new value.
11. Repeat steps 6 to 8 for other modules.
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5. AMC 300 I/O configuration

This chapter guides you through the configuration of the AMC 300 I/O modules.

5.1 Configure AMC 300 Multifunctional Inputs/Outputs

5.1.1 Set the startup parameters (EtherCAT SDOs)

1. Select the relevant I/O module (example, IOM3.2).
2. Select Startup parameters.

3. Select Add.

4. Select the setup parameters for an analogue output (example, MultiOutput_4).
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a. Output Enable
b. Mode
c. Low
d. High

5. In the Value field, set the values for the MultiOutput Startup Parameters.

Example: Multi-functional output configured as a 4 to 20 mA analogue current output. 

Parameter Value Note

a. Output Enable 0 = Output not active
1 = Output active  

b. Mode 
0 = Unknown
15 = Voltage out mode
16 = Current out mode

 

c. Low 4.0 or -10.0

Lower measured limit.
Examples:
• 4 to 20 mA
• ± 10 V

d. High 20.0 or 10.0 Upper measured limit.

6. Configure the start parameters for a multi-functional input (example, MultiInput_1).
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e. Mode
f. Low
g. High

7. In the Value field, set the values for the MultiInput Startup Parameters.

Example: Multi-functional output configured as a 4 to 20 mA analogue current output. 

Parameter Value Note

e. Mode 

0 = Unknown
1 = Voltage mode
2 = Current mode
3 = Resistance mode
4 = Temperature mode
5 = Dry Contact mode

 

f. Low 4.0 or -10.0

Lower measured limit.
Examples:
• 4 to 20 mA
• ± 10 V

g. High 20.0 or 10.0 Upper measured limit.
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5.1.2 Configuration example for PWM

The PWM signals of the IOM3‧2 can be configured like this:

5.1.3 Attach I/Os to variables

I/Os can be attached from the POU tab to variables and used in the application logic.

A simple test is to wire the terminals of the MultiOutput as feedback to the MultiInput.

After download of the application, the MultiOutput analogue value can be forced and seen on the MultiInput analogue input.
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6. AMC 600 I/O configuration

This chapter guides you through the configuration of the AMC 600 modules, usually AIO6.1 and TIM6.1.

NOTE The DIO6.1 does not need configuration via startup parameters.

6.1 Set startup parameters (EtherCAT SDOs)

1. Select the relevant I/O module, for example, AIO6.1.
2. Select Startup Parameters.

3. Select Add.

4. Select the setup parameter for an analogue output (for example, AO 1 Advanced settings > AO 1 Output type). Use the
drop-down list to select the type supported.
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Example: Analogue output configured as a 0 to 10 V analogue voltage output. 

5. Same method is used to configure Analogue input. Select the setup parameters for an analogue input (for example, AI 1
Advanced settings > AI 1 Input type).

Example: Analogue input configured as a 0 to 10 V analogue voltage input. 

6. Once added, the startup parameters are automatically transferred to the EtherCAT I/O modules.
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6.2 Attach I/Os to variables

You can attach I/Os from the POU tab to variables, and used in the application logic.

A simple test is to wire the terminals of the analogue output as feedback to the analogue input.

After download of the application, the analogue output value can be forced and seen on the analogue input.
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