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1. About this manual

1.1 Software versions

The information in this document corresponds to the following software versions.

Table 1.1 Software versions

Software Details Version

BSP Board Support Package 4.0.0.x 

CODESYS CODESYS runtime 3.5.15.0 or later 

CODESYS IDE PC software for development of CODESYS applications 3.5.15.0 or later 

CODESYS TSP AMC 300 CODESYS Target Support Package (TSP) 1.0.1.0 

1.2 Technical support

CODESYS in general

The CODESYS store 
My question: Ask questions about CODESYS.
FAQ: Frequently asked questions.
Forum: Discuss different CODESYS topics with other users.

CODESYS Development System
online help Online help is available from the Help menu. 

DEIF support options

Technical documentation Download all technical product documentation from https://www.deif.com/
documentation.

Support 

DEIF offers 24-hour support.
See www.deif.com for contact details, there may be a DEIF subsidiary located near
you.
You can also e-mail support@deif.com.

Service DEIF engineers can help with design, commissioning, operating and optimisation. 

Training DEIF regularly offers training courses at the DEIF offices worldwide. 

1.3 System requirements

The requirements for the development PC to install the Development packages, PC tools and drivers are:
• Microsoft Windows 10, 32 bit version
• Microsoft Windows 10, 64 bit version (Recommended)

As the AMC 300 supports SSH (Secure Shell) and SCP (Secure Copy) as basic communication protocols, it can be accessed
from any system supporting these protocols (if enabled).

NOTE Not all browsers are suitable for this software. We recommend to use Google Chrome or Mozilla Firefox.
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1.4 Warnings and safety

Recommendations for data security

To minimise the risk of data security breaches we recommend to:
• As far as possible, avoid exposing controllers and controller networks to public networks and the Internet.
• Use additional security layers like a VPN for remote access, and install firewall mechanisms.
• Restrict access to authorised persons.

1.5 Legal information

Disclaimer

DEIF A/S reserves the right to change any of the contents of this document without prior notice.

The English version of this document always contains the most recent and up-to-date information about the product. DEIF
does not take responsibility for the accuracy of translations, and translations might not be updated at the same time as the
English document. If there is a discrepancy, the English version prevails.

Trademarks

DEIF is a trademark of DEIF A/S.

CODESYS® is a trademark of CODESYS GmbH.

All trademarks are the properties of their respective owners.

Copyright

© Copyright DEIF A/S. All rights reserved.
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2. Installation

2.1 AMC 300 CODESYS development package

2.1.1 About the AMC 300 CODESYS development package

The AMC 300 CODESYS development package consists of two parts:
• CODESYS IDE
• AMC 300 CODESYS TSP.

The CODESYS CONTROL (CODESYS PLC run-time) is integrated in the AMC 300 operating system.

2.1.2 Download the AMC 300 CODESYS development package

You can download the CODESYS IDE and AMC 300 CODESYS TSP by submitting your email address via the DEIF website. A
link is sent to you to download the CODESYS IDE and AMC 300 CODESYS TSP respectively.

Follow these steps to download the CODESYS IDE:
1. Go to the DEIF website www.deif.com.

2. Open the search bar , and type the controller name to open a list of product options.
3. Select the controller from the list.
4. Select the Software tab.
5. Open the CODESYS list, and select AMC 300 CODESYS TSP v1.x.x.
6. Submit your email address to receive a download link to the software.

someone@someone.com

E-mail notification on future releases

Download

7. Follow the link in the email to download the DEIF CODESYS software package to your computer.
8. Repeat the steps to download the CODESYS IDE installation file.
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2.2 Install CODESYS V3

1. Run the installation file (for example, CODESYS 64 3.5.15.20.exe) to install CODESYS V3 to the development computer
with default settings.

2. If you are prompted to install necessary Microsoft Visual C++ packages, follow the instructions on the screen.

The CODESYS InstallShield Wizard
1. When the CODESYS InstallShield Wizard starts, select Next.

2. Licence Agreement: Accept the agreement and select Next.
3. Choose Destination Location: Choose a folder for the installation, and select Next.
4. Select Features: Choose the features you want to install, and select Next.
5. Select Program Folder: Choose a program folder, and select Next.
6. Start Copying Files: The chosen features and the destination folder are shown. If everything is correct, select Next.
7. Very important information: Confirm that you have read the information, and select Next.
8. InstallShield Wizard Complete: Select Finish to exit the installation wizard.
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2.3 Install the AMC 300 CODESYS TSP

1. Run the installation file (for example, AMC300-CODESYS3.5.15.20.v1.0.0.0-g80afd0a.package) to install the AMC 300
CODESYS TSP (Target Support Package) to the development computer with default settings.

2. The file extension .package is registered with CODESYS on Windows. If CODESYS is not installed or is a wrong version
you will see this message.

3. Install a correct version of CODESYS (see section Install CODESYS V3), then run the installation file again.

If CODESYS is installed, but you do not want the AMC 300 CODESYS TSP package associated with it, you can open
CODESYS and install the package file via Open > Install package.

This starts the Package Manager and install the required AMC 300 Device Descriptions (and the EtherCAT Slave
Information files).
1. Choose a setup, and select Next.

2. When the package is installed, select Next to finish the installation.
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3. Select Finish to exit the installation wizard or Next to see a summary.
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2.4 Open CODESYS for the first time

To open CODESYS you can:
• Double-click the desktop icon

• In the start menu, select Start > 3S CODESYS > CODESYS V3.5 SP15 (or later version)

The CODESYS start page:
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3. CODESYS Online Help

3.1 Start the CODESYS Online Help

Use the CODESYS Online Help to get more detailed information about the CODESYS programming environment.

On the CODESYS start page, select Help > Contents in the menu.

This opens the CODESYS Online Help page.
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3.2 New to CODESYS

If you are new to CODESYS, we recommend to start with the guide under the menu Your First CODESYS Program.

3.3 Visualization

Under the menu CODESYS Visualization you can read more about the possibilities with visualization.
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3.4 Programming references

Detailed information about programming is found under the menu Reference, Programming.

3.5 Libraries included in CODESYS

The standard libraries are described under the menu Libraries.

More information about libraries is found in the Library Manager for DEIF AMC 300 specific libraries.
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3.6 Language settings

The default language for the menu and help files is English. You can change this under Tool > Options > International
Settings to a variety of languages.

NOTE The AMC 300 CODESYS TSP must be installed before you change the language settings.
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4. Create a CODESYS project

4.1 Create a new project

To create a new CODESYS project:
1. Go to File > New Project.*

2. Select Standard project in the Templates field.
3. Write a project name.
4. Select a location path for the project file.
5. Select OK to open the Standard Project window.

6. In the Device field, select AMC 300 PCM 3.1 (DEIF A/S) as the device.
7. In the PLC_PRG in field, select Structured Text (ST) as programming language. **
8. Select OK to continue.

NOTE * You can also select Empty project if you want to create an entire project from scratch.
NOTE ** New POUs can use a different programming language.

4.2 CODESYS layout

The image below shows the terminology used for the project view throughout the CODESYS manual.
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No. Item Description

1 Project tree 

The project tree is an overview of your project.
A typical project will consist of:
• One or more devices (AMC 300 controllers).
• One or more applications containing the Libraries, POUs and tasks.

2 PLC Logic node A PLC Logic node shows that the device is a programmable device and has no other
functions associated to it. 

3 Library manager 
The Library manager contains the libraries for the project.
Each library consists of functions and function blocks that can be used in your
programs.

4 Devices tab The Devices tab gives you quick access to the project tree. 

5 POUs tab The POUs (Program Object Units) tab gives you quick access to the device
independent POUs. 

6 Working area 

The working area consists of tabs representing different parts of the project. These
project parts can be opened from the project tree.
The illustration shows the working area for the POU, PLC_PRG. The working area for
this POU consists of a declaration workspace, an implementation workspace and a
toolbox menu.

7 Declaration workspace The declaration workspace consists of the variables for the POU functions.

8 Additional toolboxes Some elements have additional toolboxes to help you build your program, for example
Visualisation. 

9 Implementation workspace The implementation workspace is used to program your POU. 
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4.3 Build from an empty project

1. Select File > New Project > Empty project.

2. Write a project name in the field Name (for example, Project1).
3. Select a location to save the project (for example, C:\Workspace\AMC 300\).
4. Select OK to continue.

4.4 Add the AMC 300

1. In the project window, select Add Device.

2. In the Add Device window, select a device from the list.
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3. Select Add Device.

4.5 Add EtherCAT master device

1. In the project window, select Add Device.

2. In the Add Device window, select a device from the list.
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3. Select Add Device.
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4.6 Connect to AMC 300

1. In the project window, double-click the AMC 300.
• A gateway with the default IP address localhost is shown.
• We recommend to create a new gateway with a new IP address or hostname for the AMC 300.

2. Select Gateway > Add new gateway.

3. Enter the hostname or the IP address for AMC 300 (for example, 192.168.20.13).

4. Select OK.
5. Select Scan Network to find the AMC 300 on the network.
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6. Select the device.
7. Select OK.
8. Select Device.
9. Select the device to set the active network path to the controller.

10. Select OK
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4.7 Setup EtherCAT master

1. Open the EtherCAT_Master tag.

2. Select Browse.
3. Select the eth0 adapter* (corresponding to EtherCAT OUT port 1 and EtherCAT OUT port 2).

NOTE *The same network adapter number for the eth0 (EtherCAT port) is used on all shipped devices.

We recommend to specify which task handles the bus communication:
• In AMC_300_PCM3_1 > PLC Settings > Bus cycle options: ◦ Specify the Bus cycle task to EtherCAT_master.
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4.8 Scan for devices

1. Login to the AMC 300.

2. In the pop-up window, select Yes to create an application.

3. Select EtherCAT_Master (EtherCAT_Master), and then Scan For Devices... in the drop-down menu.
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NOTE If EtherCAT Master is running on the AMC 300, you can scan for devices without being logged in. If a
scan fails, then use the above procedure

4. In the devices window, select Copy All Devices to Project.
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5. The devices are now displayed in the Devices tree.
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4.9 I/O module variables

IOM3‧1 variables
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IOM3‧2 variables

IOM3‧3 variables
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IOM3‧4 variables

ACM3‧1 variables
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PSM3⋅1 variables

PSM3⋅2 variables
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4.10 Add a program

1. Select Application > Add Object > POU....

2. In the Add POU window, tick Program and select Add.
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4.11 Write a program

Example of a program
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4.11.1 Add a task

1. Select Task configuration > Add Object > Task....

2. In the Add Task window, write a Task name and select Add.
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3. Select the Add Call tab.
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4. In the Input Assistant window, select the program PLC_PRG.

5. The program PLC_PRG is now added to the project.
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6. Login to the AMC 300.

4.11.2 Simulation mode

It is possible to use Simulation mode, if an AMC 300 controller is not connected.
1. Select Simulation mode with Online > Simulation.
2. Login to the AMC 300 with Online > Login.
3. In the pop-up window, select Yes to create the program.

4. Select Debug > Start to run the program.
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4.11.3 Login to AMC 300

Select Online > Login.
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4.11.4 Start the program

To start the program, select Debug > Start.
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4.12 Link I/O variables to physical I/O

1. Select Online > Logout to go to offline mode.
2. Select a physical I/O.

3. Select … of F2 to edit.
4. In the Input Assistant window, select a variable.

5. Select OK to link the variable to the physical I/O.

USER MANUAL 4189341271F EN Page 39 of 52



6. Repeat 1 to 5 for for all output variables.

4.13 Add visualization

1. Select Application > Add Object > Visualization.

2. In the Add Visualization window, activate the VisuSymbols (System) library.
3. Select Add.
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4.13.1 Drawing visualization (example)

1. Draw an ellipse in the Visualization field.
2. Select Properties > Color variation > Toggle Color to link the ellipse to a variable.
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3. Set Properties > Colors > Alarmstate > Frame color to Black.
4. Set Properties > Colors > Alarmstate > Fill color to Grey.
5. Repeat 1 to 4 (or copy-paste the ellipse) 3 times.

6. Use Toggle Color to change the new variables to other outputs.
7. Add a counter field (rectangle).
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4.13.2 Set main visualization

1. Select the WebVisualization tab.

2. In the Input Assistant window, select Visualization.
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3. Select OK.
4. Login and run the program.
5. Select Visualization to view the first page.

4.13.3 View webvisualization or remote visualization

To see the webvisualization go to either
• http://[hostname or ip]:8000/webvisu.htm (for example, http://amc300.local:8000/webvisu.htm)
• (Please note : the port is to be changed to port 8080 in later software versions)
• via secure http to https://[hostname or ip]:8443/webvisu.htm (for example, http://amc300.local:8443/)
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4.14 Create a boot project

To make the AMC 300 start with the application at power up, you can create a boot project in CODESYS.
1. Login to the AMC 300 via Online > Login.
2. Select Online > Create boot application.

3. The boot project files are created under
• /app/codesysapp/PlcLogic/Application
• /app/codesysapp/PlcLogic/visu

4. Reboot the AMC 300.

Remove a boot project
Remove a boot project and clean all the application files in /app/codesysapp/PlcLogic/Application and /app/codesysapp/
PlcLogic/visu folders.

1. Login to the AMC 300 via Online > Login.
2. Select Online > Reset origin.
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4.15 Manually force digital outputs for system testing

To manually force the digital outputs, for example for system testing, you must create a new empty project (see section
Create a new project).
1. Scan for devices.
2. Add devices.
3. Select AMC_300_PCM3⋅1 > PLC Settings.
4. Check the box Update IO while in stop.
5. In the Always update variables drop-down list, select Enable 1 (use bus cycle task if not used in any task).
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6. In the Bus cycle task drop-down list, select EtherCAT_Task.
7. Select AMC_300_PCM3⋅1 > Application [run].
8. Under a module tab, select EtherCAT I/O Mapping to see the values of all inputs.
9. Double-click Prepared value for the value you wish to change.

10. Select F7 to force the new value.
11. Repeat #6 to #8 for other modules.
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5. Configure Multi Inputs/Outputs

1. Select the relevant I/O module (example, IOM3.2).
2. Select Startup parameters.

3. Select Add.

4. Select the setup parameters for an analogue output (example, MultiOutput_4).
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a. Output Enable
b. Mode
c. Low
d. High

5. In the Value field, set the values for the MultiOutput Startup Parameters.

Example: Multi functional output configured as a 4-20 mA analogue current output. 

Parameter Value Note

a. Output Enable 0 = Output not active
1 = Output active  

b. Mode 
0 = Unknown
15 = Voltage out mode
16 = Current out mode

 

c. Low 4.0 or -10.0

Lower measured limit.
Examples:
• 4-20 mA
• ± 10 V

d. High 20.0 or 10.0 Upper measured limit.

6. Configure the start parameters for a multi functional input (example, MultiInput_1).
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e. Mode
f. Low
g. High

7. In the Value field, set the values for the MultiInput Startup Parameters.

Example: Multi functional output configured as a 4-20 mA analogue current output. 

Parameter Value Note

e. Mode 

0 = Unknown
1 = Voltage mode
2 = Current mode
3 = resistance mode
4 = Temperature mode
5 = Dry Contact mode

 

f. Low 4.0 or -10.0

Lower measured limit.
Examples:
• 4-20 mA
• ± 10 V

g. High 20.0 or 10.0 Upper measured limit.
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MultiInput error codes

Parameter Value

MI error 

-10000 = Wire break
-9999 = Input error
-9998 = Under voltage
-9997 = Over voltage
-9996 = Under current
-9995 = Over current
-9994 = Under frequency
-9993 = Over frequency
-9992 = Short circuit
-9991 = Over load
-9990 = Unsupported mode
-9989 = Unsupported range
-9988 = Unsupported configuration
-9987 = Invalid calibration

Attach I/Os to variables
I/Os can be attached from the POU tab to variables and used in the application logic.

A simple test is to wire the terminals of the MultiOutput as feedback to the MultiInput.

After download of the application, the MultiOutput analogue value can be forced and seen on the MultiInput analogue input.
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