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1. Revision

Revision Author Date Description

A SJE 2012-06-26 Initial release

B LVI 2012-08-14 Contact information updated

D LVI 2013-01-15 Updated to DEIF AWC 500 CODESYS TSP 1.04.0

E HCH 2017-11-29 Updated to DEIF AWC 500 CODESYS TSP 1.0.0.0
Updated the controller to PCM5·2

F LVI 2018-03-05 Updated to DEIF AWC 500 CODESYS TSP 1.0.1.0
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2. Overview

This document will guide you through the installation of the AWC 500 CODESYS development

package.
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3. Installing the CODESYS Development package

The steps to install the CODESYS Development package are

1. Download the latest packages from the DEIF FTP server.

2. Install CODESYS V3 with default setting to the development computer.

3. Install the DEIF AWC 500 CODESYS TSP (Target Support Package).

The package contains:

Table 3.1: Contents of the DEIF CODESYS development package

Files and folders Description

Setup_CODESYSV3XSPY (PatchZ) CODESYS installation

e.g. Setup_CODESYSV35SP10Patch1.exe CODESYS V3.5 SP10 Patch 1 (or latest) to be
installed on the PC

DEIF_AWC_500_CODESYS_V3_X_SPY_patch_
Z_TSP_vW.X.Y.Z

AWC 500 CODESYS TSP (Target Support
Package)

e.g.
DEIF_AWC_500_CODESYS_V3_5_SP10_patch_
1_TSP_v1.0.0.0.exe

AWC 500 CODESYS TSP to be installed on the
PC. Devices description files and libraries will be
installed automatically.

3.1. System requirements
The system requirements for the development PC to install the AWC 500 CODESYS Development

package is:

• Microsoft Windows XP or

• Microsoft Windows 7 32 bit or

• Microsoft Windows 7 64 bit or

• Microsoft Windows 10 32 bit or

• Microsoft Windows 10 64 bit (recommended)

3.2. Downloading the AWC 500 CODESYS package

3.2.1. Download the software from the DEIF FTP server

Download the AWC 500 CODESYS Development package from the DEIF FTP server:

ftp://support.deif.com under /AWC_500.

AWC 500 CODESYS Development package 3. Installing the CODESYS Development package
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Figure 3.1: Contents of the AWC 500 ftp site on ftp://support.deif.com

To get access to the FTP server, please contact DEIF AWC 500 support via email:

awc500support@deif.com

Navigate to the folder /CODESYS_development_package/CURRENT

Figure 3.2: Available CODESYS installations

Here select the CODESYS version you want to use on the AWC 500. Navigate to the folder e.g.

/PCM52 and download the files marked below to your PC.

Figure 3.3: Content of the AWC 500 CODESYS package
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3.3. Installing CODESYS V3
First install CODESYS V3 with default settings to the development computer by running e.g.

Setup_CODESYSV35SP10Patch1.exe.

CODESYS might require some packages to be installed on the computer prior to the installation of

CODESYS.

Downloading packages might require an internet connection.

Figure 3.4: InstallShield Wizard Microsoft Visual C++ packages

Click "Install" to install the Microsoft Visual C++ packages.
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Figure 3.5: Microsoft Visual C++ packages installing

Then wait for the installation to finish.

Once it is done, click "Next":

Figure 3.6: InstallShield Wizard for CODESYS V3.5 SP10

Click "I accept the terms of the license agreement" and click "Next":
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Figure 3.7: InstallShield Wizard for CODESYS V3.5 SP10

Click "Next":

Figure 3.8: InstallShield Wizard for CODESYS V3.5 SP10

Click "Next":

AWC 500 CODESYS Development package 3.3. Installing CODESYS V3

www.deifwindpower.com Page 7 of 93



Figure 3.9: InstallShield Wizard for CODESYS V3.5 SP10

Click "Next":

Figure 3.10: InstallShield Wizard for CODESYS V3.5 SP10

Click "Next":
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Figure 3.11: InstallShield Wizard for CODESYS V3.5 SP10

Click "I have read the information" and Click "Next":

Figure 3.12: InstallShield Wizard for CODESYS V3.5 SP10

Click "Finish".
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Figure 3.13: InstallShield Wizard for CODESYS V3.5 SP10

3.4. Installing AWC 500 CODESYS TSP (Target Support Package)
After installing the CODESYS V3 to the development computer, continue installing the AWC500

CODESYS TSP (Target Support Package) by running e.g.

DEIF_AWC_500_CODESYS_V3_5_SP10_patch_1_TSP_v1.0.0.0.exe

It is recommended to install with default settings. If CODESYS is not yet installed or wrong version you

will see this message and be prompted to install it first.

Figure 3.14: The AWC 500 CODESYS TSP detects if the right CODESYS version is installed

In this case, you are offered the download of CODESYS automatically from DEIF’s support site:
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Figure 3.15: The AWC 500 CODESYS TSP can download the CODESYS package directly

Continue the CODESYS installation as described above, then run installation of the AWC500

CODESYS TSP (Target Support Package) e.g.

DEIF_AWC_500_CODESYS_V3_5_SP10_patch_1_TSP_v1.0.0.0.exe again. Click "Next":

Figure 3.16: AWC 500 CODESYS TSP Installation

Click "Next":
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Figure 3.17: AWC 500 CODESYS TSP Installation

Click "Next":

Figure 3.18: AWC 500 CODESYS TSP Installation

Wait for the libraries to be installed:

AWC 500 CODESYS Development package3.4. Installing AWC 500 CODESYS TSP (Target Support Package)

www.deifwindpower.com Page 12 of 93



Figure 3.19: AWC 500 CODESYS TSP Installation

Wait for the device descriptions to be installed:

Figure 3.20: AWC 500 CODESYS TSP Installation

You will hereafter be prompted to update the CODESYS Control Runtime on the AWC 500. Click "Yes"

to do it now, or "No" to do it later:

Figure 3.21: AWC 500 CODESYS TSP Installation

Then enter the IP, username and password for the AWC 500 unit, and click "OK":

AWC 500 CODESYS Development package3.4. Installing AWC 500 CODESYS TSP (Target Support Package)

www.deifwindpower.com Page 13 of 93



Figure 3.22: AWC 500 CODESYS TSP Installation

Click "No" if you do not have any other AWC 500 units to update:

Figure 3.23: AWC 500 CODESYS TSP Installation

Finally click "Finish" to end the installation.
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Figure 3.24: AWC 500 CODESYS TSP Installation

3.5. AWC 500 CODESYS TSP files location
The CODESYS TSP has installed the files in this locations on the PC:

Figure 3.25: AWC 500 CODESYS TSP Installation

3.5.1. AWC 500 Device description files

These are automatically installed in the CODESYS installation when running the TSP.
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Figure 3.26: AWC 500 CODESYS and EtherCAT Device description files

3.5.2. AWC 500 CODESYS libraries

These are automatically installed in the CODESYS installation when running the TSP.

Figure 3.27: AWC 500 CODESYS libraries
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3.6. Opening CODESYS first time
Firstly open the CODESYS V3. Either via desktop icon

Figure 3.28: CODESYS V3.5 SP10 desktop icon

Or via Start menu "Start→3S CODESYS→CODESYS V3.5 SP10 (or later version)":

Figure 3.29: Starting CODESYS V3.5 SP10 from start menu

This will open the CODESYS:
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Figure 3.30: The CODESYS


It is important to update projects using the previous versions of CODESYS to

the new installed CODESYS version. This can be done by right clicking

"Device" and selecting "Update Device", else the previous version of

CODESYS devices and libraries are used.

You will notice this if there is a ? in front of the device.

Figure 3.31: ? telling that the Device needs to be updated
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Figure 3.32: Updating the Device to latest installed version
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Figure 3.33: The installed AWC 500 version e.g. 3.5.10.10

Then update the Project environment settings if a newer version exists, first the compiler version:
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Figure 3.34: Project environment settings update, Compiler version

No update is needed in Figure 3.34 because the current version is the newest.

Then the visualization profile:
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Figure 3.35: Project environment settings update, Visualization profile

No update is needed in Figure 3.35 because the current version is the newest.

3.7. Updating CODESYS Control runtime on AWC 500



Update of CODESYS Control is only required

• If updating to a new AWC 500 CODESYS development package.

• If the operating system has been update.

• If connection to the AWC 500 via CODESYS fails after trying all other

possibilities.

Else update is not required and skip this section.

It is highly recommended to update the CODESYS runtime on the AWC 500 via Web interface. First,

go to http://[ip]/sys/ e.g. http://192.168.20.13/sys/. In the web page, click on "Tools" icon, and then click

"Firmware update".
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Figure 3.36: Web interface - "Tools" page

Next, Click on "Choose File" button. The file Explorer window will pop up, where you select the

"PCM52_CODESYS_runtime_vPCM52-W.X.Y.Z.dupdate" file under \runtime.

Then click "Open"

Figure 3.37: Pop-up window - upload file

It will return to the web page, and you can see the dupdate file being uploaded to the page. Click on

"Upload" button
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Figure 3.38: Web interface - ready to upload

A small pop-up window will prompt you to enter the Username and Password.

Figure 3.39: Pop-up window - enter username and password

You can see a line of text on the web page indicating the status of upload.

AWC 500 CODESYS Development package 3.7. Updating CODESYS Control runtime on AWC 500

www.deifwindpower.com Page 24 of 93



Figure 3.40: Upload successful

If the upload is successful, reboot the AWC 500 by clicking on the "Reboot" button. Then click "OK"

Figure 3.41: Reboot

You can also view the status via System logs, "Tools→System logs".
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Figure 3.42: Example of logs on web interface
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Alternatively, you can update the CODESYS runtime on the AWC 500 via WinSCP.



Make sure your SFTP program or here WinSCP has disabled transfer to

temporary file. E.g. in WinSCP:

"WinSCP→Tool→Preferences→Transfer.Endurance→Enable transfer

resume/transfer to temporary filename for: Disable"

Make sure Endurance setting is changed from "Enable" to "Disable"

locate the "PCM52_CODESYS_runtime_vPCM52-W.X.Y.Z.dupdate" file under \runtime and

copy it to /tmp/fwupdates folder on AWC 500. Reboot AWC 500.

Figure 3.43: Updating the CODESYS runtime

Status of the update is written to /data/log/syslog:
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Figure 3.44: The syslog folder

Click on relevant file in the syslog to view the status. e.g. "current" file

This is an example of successful update in "current" file:

Figure 3.45: Example of successful update

To view with human readable timestamps, login to AWC 500 via PuTTY, and then use logc
command to view log.
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Figure 3.46: View via PuTTY

logc tail syslog will print the last 10 log information

logc cat syslog will print all the log information

3.8. Updating device information in previous projects
If new device descriptions have been installed, then the device information needs to be updated in

existing projects, open the existing project:
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Figure 3.47: Update Device

Select "Update Device" on all Devices and modules.

Figure 3.48: Repeat the update for subsequent modules
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And repeat the update for subsequent modules.

4. Changing CODESYS language settings

 Only change language settings AFTER the AWC 500 Device descriptions and

libraries have been installed.

The language settings (menu and help files) can be changed from English to e.g. German or Chinese.

Go to "Tool→Options…"

Figure 4.1: Select "Tools→Options…"

Under "International Settings" the language can be changed:
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Figure 4.2: International Settings

Split language setting e.g. the User interface in English and the online help file in Chinese is also

possible:

Figure 4.3: Setting language for user interface and online help

5. Using the CODESYS Help

5.1. Contents
We recommend that you read more about using the CODESYS in the CODESYS Online help
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("Help→Contents" or "Help→Index")

Figure 5.1: Starting the CODESYS Help

Here you can get more detailed information about the CODESYS programming environment:

Figure 5.2: CODESYS Help Contents

5.2. Difference from CODESYS 2.3 to CODESYS 3
If you already have an existing CODESYS project (.project file), then it may be useful to read about the

changes from CODESYS 2.3 to CODESYS 3:
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Figure 5.3: CODESYS Help Contents - opening CODESYS 3 project
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Figure 5.4: CODESYS Help Contents - opening CODESYS 2.3 project

See Chapter Changing language settings if you want to view the documentation in Chinese language:
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Figure 5.5: CODESYS Help Contents - opening CODESYS 3 project in Chinese language

5.3. First CODESYS program
If you are new to CODESYS try starting with the "Your first CODESYS program" guide in the help file:
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Figure 5.6: CODESYS Help Contents - "Your first CODESYS program"

5.4. Visualization
You can read more about the possibilities with the Visualization:
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Figure 5.7: CODESYS Help Contents - Using the visualization

5.5. Programming references
For more detailed information about programming, please see the "Reference, Programming" section:
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Figure 5.8: CODESYS Help Contents - "Reference, Programming"

Here you find information about e.g. Keywords and Datatypes:
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Figure 5.9: CODESYS Help Contents - Datatypes
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Figure 5.10: CODESYS Help Contents - Datatypes in Chinese language
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Figure 5.11: CODESYS Help Contents - Keywords

AWC 500 CODESYS Development package 5.5. Programming references

www.deifwindpower.com Page 42 of 93



Figure 5.12: CODESYS Help Contents - Standard Datatypes
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Figure 5.13: CODESYS Help Contents - Extended datatypes
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Figure 5.14: CODESYS Help Contents - Operators

5.6. Libraries included in CODESYS
The standard libraries are described under Libraries. Please also see the DEIF AWC 500

Documentation "IEC61131-3 programming" for libraries specific for AWC 500:
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Figure 5.15: CODESYS Help Contents - Libraries

5.7. Index
Alternatively, you can search in the index ("Help→Index"), then write the keyword or datatype you want

documentation about:
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Figure 5.16: Example on using Index to look up a "STRING" datatype

6. Creating the first CODESYS project

The small tutorial guides you on how to make a new project from scratch, with Program POU, Task

configuration, and IO linking and Visualization (and remote visualization).

Detailed assistance on using CODESYS can be found in "Help→Contents" inside CODESYS.
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Figure 6.1: Online help

6.1. Create a new project
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Figure 6.2: New Project

Alternatively, choose the "Standard project" to get start programming directly.

6.2. Add the AWC 500 device
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Figure 6.3: Add device

AWC 500 CODESYS Development package 6.2. Add the AWC 500 device

www.deifwindpower.com Page 50 of 93



Figure 6.4: Add device window

The project startup looks like this:
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Figure 6.5: Project startup

6.3. Add EtherCAT master device

Figure 6.6: Add device
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Figure 6.7: Add device window

The project looks like this after adding EtherCAT master device:
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Figure 6.8: Project with EtherCAT master device added

6.4. Establish connection to the AWC 500.
Double click the AWC 500 device. You will see one existing gateway with the default IP address

"localhost".

If this is not the desired IP address, you can create a new gateway with new IP address.

"Gateway→Add new gateway",

Figure 6.9: create new gateway

Enter the IP for the AWC 500 unit (e.g. 192.168.20.13) and click "OK".
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Figure 6.10: change IP address

Once a new gateway is created, select "Scan network". This will find the AWC 500 on the network.

Figure 6.11: Scan network

Select the device and click "OK".
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Figure 6.12: Select the device

6.5. Setup EtherCAT master
Open EtherCAT_Master tag.

Figure 6.13: Setup EtherCAT master

Select "Browse…" and select the adapter with the name "eth0" (corresponding to EtherCAT OUT port

1 and EtherCAT OUT port 2).
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Figure 6.14: Select network adapter

The same network adapter number for the eth0 (EtherCAT port) is used on all shipped devices

It is recommended to explicitly specify what task handles the bus communication:

• In "AWC_500_PCM5_2→PLC Settings"

"Bus cycle options":

◦ Specify "Bus cycle task" to "EtherCAT_master"

Figure 6.15: PLC Settings

6.6. Scan for IO modules
First login to the AWC 500.
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Figure 6.16: Login to the AWC 500

Figure 6.17: Create application
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Figure 6.18: Scan for devices


It is possible to scan for devices without being logged in to the AWC 500. It only

requires that the EtherCAT master is running on the AWC 500. If a scan fails, do

Login and Reset cold, then use the above procedure.

Found devices are then displayed
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Figure 6.19: Scan for devices

Select "Copy all devices to project"

Figure 6.20: The project after the devices have been added

This adds our modules to the project, here the PCM52 variables:
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Figure 6.21: The PCM52 variables

The IFM5_1 variables:

Figure 6.22: The IFM5_1 variables
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The IOM5_1 variables:

Figure 6.23: The IOM5_1 variables

The GPM5_1 variables:
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Figure 6.24: The GPM5_1 variables

6.7. Add Program (Application→Add Object→POU…)
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Figure 6.25: Add program

AWC 500 CODESYS Development package 6.7. Add Program (Application→Add Object→POU…)

www.deifwindpower.com Page 64 of 93



Figure 6.26: Add POU

6.8. Write a little program
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Figure 6.27: Program example

6.9. Add task (Task Configuration→Add Object→Task…)
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Figure 6.28: Task configuration
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Figure 6.29: Add Task

Use "Add Call" to point at the program PLC_PRG
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Figure 6.30: Use "Add Call" to point at the program PLC_PRG
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Figure 6.31: Input assistant
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Figure 6.32: PLC_PRG added

Now we are ready to login to the AWC 500.

Please note it is possible to use simulation mode if no physical AWC 500 connected.

Change to Simulation mode in "Online→Simulation". Login to the AWC 500 in simulation mode with

"Online→Login".

Figure 6.32: Create application

Click "Yes". "Debug→Start" to run the program.
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Figure 6.33: Running program

6.10. Login to the AWC 500 (Online→Login)
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Figure 6.34: Select Online→Login

6.11. Start the program (Debug→Start)

Figure 6.35: Start the program
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Figure 6.36: Program started

6.11.1. Link the IO variables to physical IO

In offline mode ("Online→Logout") the IO variables can be linked to physical IO:
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Figure 6.37: IO variables

Select the physical channel and press "…" or F2 to edit.
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Figure 6.38: Input assistant

Figure 6.39: Example of variable linked to IO
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Repeat for all outputs variable.

Figure 6.40: Example of multiple variables linked to IO
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Figure 6.41: PCM 5·2 example

6.12. Add visualization (Add Object→Visualization…)
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Figure 6.42: Select visualization…
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Figure 6.43: Add visualization…

Draw a little Eclipse
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Figure 6.44: Drawing visualization

Link the eclipse to a variable under Toggle Color (use F2 for input assistant)

Figure 6.45: Link the eclipse to a variable
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Change "Frame color" on "Alarmstate" to black and "Fill color" to gray:

Figure 6.46: Change Color on alarm

Repeat (or copy paste the eclipse four times) and change the variable under Toggle Color to different

output.

And then add the counter field (Rectangle):
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Figure 6.47: Now the visualization canvas should look like this

Figure 6.48: Add the counter variable
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6.13. Set main visualization

Figure 6.49: Open the WebVisualization tab

Point to the visualization pane
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Figure 6.50: Point to the visualization pane

Now login and run the program.

Click "Visualization" to view the first page:
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Figure 6.51: Visualization

6.14. View webvisualization or remote visualization
To see the webvisualization go to http://[ip]:8080/webvisu.htm e.g. http://192.168.20.13:8080/

webvisu.htm

Figure 6.52: WebVisualization url

6.15. Creating a boot project (Online)
To make the AWC 500 start with the application each time at power up, a boot project is created in

CODESYS.

Remember to login to the AWC 500 first via "Online→Login", and then create the boot application via

"Online→Create boot application".
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Figure 6.53: Create boot application

On the AWC 500 the boot project files will then be created under:

/app/service/codesys/app
/app/service/codesys/visu

Reboot the AWC 500. The application should start running again which can be viewed from

webvisualisation.

To remove the boot project and clean all the application files in /app/service/codesys/app and

/app/service/codesys/visu folders. First, login to the AWC 500 on CODESYS, then "Online→Reset

origin".
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Figure 6.54: Reset origin

6.15.1. Source code protection

To protect the source code from unintended or unauthorized access, the project can be read and write

protected with passwords. Select "Project→Project Settings", then the category "Security", activate

"Enable project file encryption" and select the option "Password".
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Figure 6.55: Project setting
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Figure 6.56: Security option

6.16. Manually Force Digital outputs for system testing
The CODESYS contains the system configuration software. To manually force the digital outputs, e.g.

for system testing

Create a new empty project. Scan for devices, add devices, make sure to select "Enable 1(use bus

cycle task if not used in any task)" in Always Update variables section in AWC_500_PCM5_2. Then

login and run the project.

For more details regarding creating project, refer to Chapter 6 "Creating the first CODESYS project"
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Figure 6.57: Always Update variable

Then on each IOM in EtherCAT I/O pane, you can see the values of all inputs and force the Digital

Output and Analogue outputs by double clicking the "Prepare Value", then force the new value by

pressing F7.
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Figure 6.58: Forcing values

7. Troubleshooting

1. The EtherCAT network will not run

◦ Make sure the order of the modules in the software, fits the physical order in the rack (e.g.

that two modules are not in switched positions).

2. I cannot find "Library repository" and "Device repository". The images here do not look

like my installation of CODESYS.

◦ Make sure you have installed the latest version of CODESYS 3.5 SP10.
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DEIF A/S reserves the right to change any of the above.
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