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1. About DEIF MVR USW

1.1 About DEIF MVR USW

DEIF MVR USW Utility Software tool is a program used for setting and making configurations for MVR-200 series protection
and control devices. The program uses a modern graphical interface to create a user-friendly configuration.

DEIF MVR USW can be used for both reading and writing configurations to MVR-200 units. The USW is also capable of
reading disturbance recordings from the device. These recordings can be further evaluated by using the USW program,
which is included in the DEIF MVR USW software suite.

Relay settings are stored as a single .aqs file, which includes all the user settable configurations, such as protection,
measurement, communication, logics, and more. The .aqs files can be saved and stored on a hard drive, and configurations
can be done both online and offline.

DEIF MVR USW can be run by any Windows 7/8/10 version. It can be downloaded free of charge from the DEIF website
https://www.deif.com/software.
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2. Getting started

2.1 Installing the DEIF MVR USW setting tool

Launch the DEIF MVR USW Offline Installer. If you do not have the installer, you can download it for free from https://
www.deif.com/software.

Select the installer language and follow the step-by-step instructions to install the software.

NOTE Firewall software may detect DEIF MVR USW. Select Allow connection or manually include DEIF MVR USW in the
list of allowed programs.

2.2 Updating the DEIF MVR USW setting tool

If the installed DEIF MVR USW version is too old for the firmware in the relay, it may be necessary to update the setting tool
software. Find the latest firmware on https://www.deif.com/software

2.3 Connecting to a relay with DEIF MVR USW

2.3.1 Relay IP addresses

MVR-200 series relays are equipped with two RJ45 ports, one in the front panel, and one in the back. Both can be used to
connect the relay to DEIF MVR USW.

Front port Back port 

Front port (DHCP server)
The front port has a fixed IP address (192.168.66.9) and a built-in DHCP server capability. This means that a local PC will get
the required IP address automatically from the relay. If the PC is unable to connect to the relay through the front port,
change the IP address of the PC Ethernet port manually to the same area (192.168.66.x).
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To connect to the front port, click on the drop-down menu at the middle of the main tool bar, select Front Port and press

Connect.

Back port
The IP address of the MVR back port is set by the user and can be found by going to Communication > Connections. The
addresses found under this tab define the rear Ethernet communication of the relay. The IP address can also be found in
the routine test reports that were sent with the device.

Firmware upgrade and communication protocols only work through the back port.

More information
See Updating firmware in this document for more information about the firmware.

2.3.2 Setting the IP address for communication through the back port

You can set the IP addresses in the relay to match the IP address range of your PC by going to Communication >
Connections. The addresses found under this menu define the Ethernet communication of the relay. Most important
addresses are the IP address and the Gateway.

To check your IP address range, navigate to the network settings of the programming PC. In Microsoft Windows 7 and 10 it
can be found through the following path:

If you have a fixed IP address, it is shown here. If you are connecting through the front port, it is enough to select Obtain an
IP address automatically in the network settings of your PC.
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2.3.3 Direct connection

When you are connecting directly to the device without having a network connection, you need to set the IP address
manually for your programming PC. It is done through network settings.

Set the PC's IP address to the same range with the relay you are connected to: it is otherwise the same but the last three
digits need to be different.

2.3.4 Connecting relays into the same network

Open the Windows Command Prompt by typing cmd into the Search bar (in Windows 10: Start > Search, or click the
magnifying glass next to Start) and open the program. In Command Prompt, type ipconfig and press Enter.

Check the IP address of your programming PC form the provided information (under IPv4 Address). In this example it is
192.168.56.1.

Select the IP address for the relay you want to connect to the network. In this example we select the address 192.168.56.2.
Make sure the selected address is available: type ping [the selected IP address] and press Enter. When the selected IP
address is confirmed to be available, set it as the new IP address for the relay in its HMI and test the connection.
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2.3.5 Connecting through the back port

To connect to an MVR-200 series device, type the IP address to the IP address box and then either press the Enter key or
click Connect. When you are connected to a relay, the red Offline text at the top left corner will turn into a green Online.
When you are connected to a relay through DEIF MVR USW, the Arcteq logo will blink on the device to indicate an active
connection.

Only one computer can connect to a relay at a time. Attempts to connect to a relay with a second computer will not disrupt
the user who connected to the relay first.

Connecting to a relay with DEIF MVR USW through the back port does not affect the SCADA connection.

2.3.6 Device list

Another way to connect to a device is to open the Device list from the Tools menu or by pressing F11. The resulting pop-up
window shows all the available devices that are connected to the network your computer is in. Double clicking one of the
devices in the list, or selecting a device and clicking the Connect button will close the window and connect to the selected

device. If new devices are connected while the Device list is open, press the Refresh button  to make the new devices
appear on the list.

NOTE • Some switches and firewalls may prevent DEIF MVR USW from showing this list.
• If you have multiple instances of the DEIF MVR USW setting tool running at the same time, the device list will

not be able to list the devices in the network.

2.3.7 Connecting by launching DEIF MVR USW through command line

DEIF MVR USW supports connecting to a device as the USW is launched through a command line. Open the Command
prompt and simply give the command DEIF MVR USW.exe c- [the device's IP address]. This will launch the USW and
attempt to connect to the device with the given IP address.

For example, if the unit's IP address is 192.168.100.100, you can connect to it when you launch DEIF MVR USW in the
Command prompt by typing DEIF MVR USW.exe -c 192.168.100.100.

2.4 The Settings menu

General settings
The Settings menu can be found at Tools > Settings.
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The Aqs path defines the location where the configuration files are saved when they are downloaded from the MVR-200
series device with the Get aqs file command. The DR path defines the location where the disturbance recordings
downloaded from the MVR-200 series device are saved when the relay receives the Get DR files command. The Date
format has a drop-down menu of options how to display the date.

Checking the Allow mouse scrolling on combo boxes check box allows the user to change the combo box value by
scrolling the mouse wheel when the mouse hovers over the box.

DEIF MVR USW will use the language that was chosen in the Language parameter in the General menu.

Shortcuts
In the Shortcuts tab, you can edit the various menu shortcuts. By default the shortcuts are as shown in the image below.
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3. Managing .aqs files

3.1 Reading .aqs setting files from the device

With DEIF MVR USW you can download existing .aqs files from the relay and store them on the hard drive. To determine
where the .aqs files are saved, go to Tools > Settings and set the Aqs path. By default, the .aqs files are saved to the folder
C:/Users/username/AppData/Local/DEIF/MVR Utility Software/SettingFiles.

To download a relay settings to the DEIF MVR USW setting tool, connect to the device and go to Commands > Get aqs-file,
or press Ctrl+G. Wait for the program to load the file. The .aqs file is saved to the set location Settings > General > Aqs
path.

If an .aqs file is saved to a folder that already contains a file with the same name, you have two options:
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• Click OK: The new file replaces the old.
• Click Cancel: The new file is automatically renamed and both files are preserved.

3.2 Opening and saving .aqs files

You can open an .aqs file from the PC hard drive by using the command File > Open. The .aqs files can be found by
following the path determined in the Settings menu or somewhere else on the PC hard drive.

To save an .aqs file, click File > Save or File > Save as.

3.3 Uploading .aqs files to the device

You can upload an .aqs file that is currently open to the relay. First make sure that the connection to the device has been
established, and then use the menu command Commands > Write to relay and select all components you want to upload.
Then wait for the program to finish processing the command. If all parameters are written to the device, DEIF MVR USW
needs to know whether or not the communication settings are reconfigured as well.

• Click Yes: The new communication settings are sent to the relay.
• Click No: The existing communication settings will be used.
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4. Uploading configurations

4.1 Change a relay configuration

There are several ways to write changes you have made to your relay configuration. The two most common ways are Write
to relay and Write changes.

4.2 Write to relay

The following window appears when you click on the Write to relay command in the Commands menu (if a relay is

connected).

Click the check boxes to choose which parts of the configuration you want to upload:

Function Description

Settings Includes all parameter values (for example, protection pick-up levels, trip delay times, LED/DI/DO
namings, IP settings, and more). 

Logic Includes configurations made to the matrix, the control blocks and the logic editor. 

Disturbance
recorder Turns on the uploaded disturbance recorder settings. 

Mimic Uploads the mimic and the carousel designs to the relay. 

IEC 61850 Uploads the .CID file currently in use at Tools > Communication > IEC61850.

DNP3 Uploads the DNP3 settings currently in use at Tools > Communication > DNP3.

Alarms Uploads the alarms settings at Tools > Events and logs > Set alarm events.

IEC 103 Uploads the IEC103 settings currently in use at Tools > Communication > IEC103.

IEC 104 Uploads the IEC101/IEC104 settings currently in use at Tools > Communication > IEC101/IEC104.

Modbus cfg Uploads the custom Modbus configuration setup at Tools > Communication > Modbus map.

Sync time Syncs the relay clock to the time on the connected PC. If either serial time sync or NTP time sync is in
use, these remain in use. 

You can also use one of the presets Configuration or Everything.

4.3 Write changes

This window displays two values: the old value that is currently in the relay, and the new value to be written to the relay.
Write changes writes the listed parameters.

4.4 Live Edit

If DEIF MVR USW setting tool is connected to the relay, you can write parameter settings to the device in real time by
checking the Live Edit box at the top of the screen.
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Live editing means that when you make changes to the parameters in DEIF MVR USW, they are immediately uploaded to the
device. You can live edit text parameters, drop-down box parameters and numbered parameters.

When you activate the Live Edit mode, DEIF MVR USW will upload to the relay all the parameter values that are currently in
use. If there are any parameters that you have changed while not in Live Edit mode that you wish to upload to the relay, you
can do so through Commands > Write changes or Commands > Write to relay. If you have made any changes to
parameters without uploading them and then activate the Live Edit mode, these changes are wiped and replaced by the
parameter values that are currently in use in the relay.
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5. Online Edit menus

5.1 Introduction and navigation

After you open an .aqs file, some menus appear to the left side of the DEIF MVR USW window. The number of menus
depends on the device type. All the settings and values that reside under these menus can also be accessed via the
device's HMI display.

Every menu is divided into tabs which can be seen at the top of the window right below the selected menu's title. You can
change the value of a drop-down menu by clicking it and selecting one of the options, or by placing the cursor on it and
scrolling through the options with the mouse wheel (this feature must be enabled first at Tools > Settings > General >
Allow mouse scrolling on combo boxes).

More information
For a complete description of protections and other functions, refer to the MVR-200 manuals at deif.com.

5.2 General menu

The General menu's Device Info tab consists of basic information about the relay:

Setting Description

Device name The unit name set by the user. This name will be included in the .aqs configuration file name when the
file is loaded from the relay. 

Device location The unit location set by the user. This name will be included in the .aqs configuration file name when
the file is loaded from the relay. 

Serial number Unique serial number for identification purposes. Does not inhibit you from loading the same file to
another unit with the same hardware and software. 

SW version The software version in use. 

HW conf. The hardware configuration. Hardware and software order code of the unit. 

The Device info tab also has some basic settings available:
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Setting Description

Time sync. source Chooses whether the internal clock is used or whether the time is synchronized via NTP or a serial
protocol (see Commands menu > Time settings in this document).

Enable object
control
confirmation 

When enabled, the relay asks for confirmation after a control command has been given to an object
through the HMI mimic before executing the command. 

System phase
rotating order at
the moment 

Displays the system phase rotating order used at this moment. Can be either A-B-C or A-C-B. 

System phase
rotating order
setting 

Sets the system phase rotating order. 

Language Chooses the language used by the relay (see Commands menu > Uploading language files in this
document).

UTC time Time of the relay's clock in UTC format (Coordinated Universal Time). 

Clear events Clears events recorded into relay. 

LCD contrast MVR-210 series: Adjusts the contrast of the LCD display.
MVR-250 series: Adjust the display brightness from 0 to 8 (default setting: 4).

Return to default
view 

The time (in seconds) how long it takes for the relay to return to the default view from the mimic view.
If the delay is set to 0 s (default setting), the relay will not go back to the mimic view automatically. 

Reset latches An alternative to using the Back button in the front panel of the relay. 

Measurement
recorder 

Enables the Measurement recorder function (see Tools menu > Miscellaneous tools > Measurement
recorder for detailed information about this function).

Clear active
alarms Resets the active alarms. 

I/O Default object
selection Defines which object open/close status I and 0 button LEDs follow in the front panel of the relay. 

Reset latches DI Determines an alternative to using Back button in the front panel of the relay. 

If the Live Edit mode is activated, you can quickly check the state of the protection stages and the status of the objects in
use from the Protection, Control and Monitor profiles at the bottom of the General menu.

Function comments
You can write comments for activated functions in the Function comments tab in the General menu. For example, you can
write notes when your parameters were last changed.

You can also write comments in the functions' own Settings menu.

5.3 Protection menu

The Stage activation tab is the main tab in the Protection menu. Here you can activate and disable protection functions.
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The available protection functions in the configuration depends on the device type. After you have activated a function, its
parameters and other information can be found by navigating to its tab. For example, if you activated the I> function (the
over-current function) listed under Current stages in the Stage activation menu, you are able to access its settings from
the Current menu. Each activated function has the following subsections or tabs.

Info tab
After a function has been activated, opening the function's menu automatically opens into the function's Info tab. The Info
tab displays information related to the function such as statistics on starts and trips, measurements and the active settings.

Setting Description

Setting control
from comm bus Some functions allow you to enable setting changes through a remote connection (SCADA). 

Meas. side If the unit has more than one current measurement card, some functions may require you to choose
which card the relay supervises. 

Condition Displays the status of the function if the Live Edit mode is activated. Otherwise, it displays the status
of the function when the .aqs file was saved.

Phases condition Some functions display status of each phase (start and trip). 

Expected
operating time 

Displays the expected operating time with the measured values at that time. Especially useful when
testing inverse curve delays. 

Time remaining to
trip Displays how much time remains to the next trip with the currently measured values. 

Xmeas/Xset at the
moment

Displays the ratio between the measured value and the set operating level at that moment. When the
measured value is exactly at the operating level, a value of 1.00 is displayed for Xmeas/Xset.

Measured
magnitude 

Some functions give you the option of choosing the measured magnitude (usually this is a choice
between RMS values, TRMS values and peak-to-peak values). 

The Characteristics graphs section of the Info menu is found in most of the protection functions.
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The graph gives us useful information on the settings currently in use. If the Live Edit mode is activated, the graph also
shows us visual information of the function's status at a given moment. In the example above, the image on the left shows
the time delay settings in a graph form. The image on the right shows a vector graph of the measured currents vs. the pick-
up level.

Settings tab
You can change the settings of the function in the Settings tab. The range of the setting for each parameter is displayed
below its text box. The minimum step for the parameter is in the square brackets.

In the example, the unit of the parameter is xIn (multipler of I nominal), the minimum setting value is 0.10, the maximum
setting value is 50, the minimum step is0.01, and the currently used setting value is 1.2 xIn.

More information
For instructions on how to set up each individual protection function, refer to the MVR-200 manuals at deif.com.

Registers tab
The Registers tab contains two views:
• Operation event register.
• General event register.

Operation event register displays information about the function's alarms and trips. The tab only displays the measurement
values that are relevant to the actual function. Each function registers its operation into the last 12 time-stamped registers.
The values recorded into registers contain information such as the time stamp, the fault type, the pre-triggering
measurement value, the fault measurement value, etc. You can find a more detailed explanation of what each of the register
columns records in the Designers Handbook at deif.com.

When you open an .aqs configuration that has been downloaded from the relay, DEIF MVR USW displays the registers
recorded to the .aqs at the moment of download. If the Live Edit mode has been activated, DEIF MVR USW displays the
registers in real time. To clear the registers, select Clear in the Clear registers drop-down menu that is located below the
table.

General event register displays events recorded by the function. The relay records any event that has been activated in the
Events tab. These events can be also viewed at Tools > Events and logs > Event history.
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I/O tab
The I/O tab is divided between the Direct output control tab and the Blocking input control tab.

In Direct output control the function's output signals can be used to switch output the statuses of signals and user LEDs
ON or OFF. The available output signals vary depending on the function. The matrix has two kinds of connections for output
contacts:
• Connected.
• Connected and latched.

The connected output is activated or released, when the input is activated or released. Similarly, the latched connection
output signal is activated when the input is activated; however, the output remains active until it is cleared manually from
the device's panel by pressing the Back button. A latched signal can also be reset remote terminal unit. See the diagram
below describing the difference between normal and latched signals.

Click on the crossing point of an input signal and an output signal to make a connection. Then choose None, Connect, or
Latch.

In MVR-25x series devices you can choose the color of the LED when making the matrix connection. The available colors
are green, red and orange. When the matrix has been configured, upload the logic with Commands > Write to relay.

The Blocking input control tab is used to determine which signals block the function. By default no signals block any
function. Click Edit at the bottom of the window to set the blocking signals of the function. A list of different signals
appears.
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In the example, we are setting up signals that would block the I0> (earth fault) function. The Protection OFF signal (a
renamed, programmable control switch) is connected which means that whenever this signal is true, the I0> stage is
blocked. The logic must be uploaded to the relay with Commands > Write to relay for the changes to take effect.

Events tab
You can select which events are recorded into the Event history by setting the Event mask dialogue. To set the dialogue,
click on the number box.

A pop-up window appears where you can select which event types are recorded. After this the recorded events will show
up in the Event history (Tools > Events and logs > Event history or Ctrl+Shift+E). The recorded events can also be
checked in the HMI if the Events screen has been applied to the carousel (see Tools > Carousel Designer for more
information).

5.4 Control menu

5.4.1 Control menu

5.4.2 Controls enabled

The Controls enabled tab is the main view of the Control menu, and it is used to activate and disable control functions,
controllable objects and indicators. Once the functions are activated, they can be adjusted in the Control functions tab.
Objects and indicators can be adjusted in the Objects tab.
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5.4.3 Setting groups

In the Setting groups tab you can set the number of setting groups used, determine which signals set the setting groups
on, and force a setting group change. The SG local select subsection determines which digital inputs or logical signals set
the setting groups on. The new setting group configuration must be uploaded to the relay with Commands > Write to relay
for the changes to take effect.

For example, let us set the Used setting groups from SG1 to SG1...3.

Let us see what happened to the menu of a protection function (for example, Protection > Overcurrent > Settings). As can
be seen in the image below, there are now four setting groups available. Note that when new setting groups are added, the
parameter settings may not be the same as in the default SG1. When a new setting group has been added for the first time,
it appears with the default settings.
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You can bypass the setting group selection logic and force the activation of a wanted setting group. This is useful, for
instance, during commissioning where the tester is not able to activate the signals which would set the desired setting
group into use. In the image below, Force SG change has been enabled and the desired SG has been set to SG2.

5.4.4 Control functions

This tab is used for setting up the control functions activated in the Controls enabled tab. You set up control functions in
the same way you set up protection functions.

5.4.5 Device I/O tab

Binary input and output settings
The Binary input settings include the following digital input settings:
• The polarity.
• The activation and release threshold voltage levels.
• The activation and de-activation delays.
• Enables and disables the 30 millisecond delay that accounts for alternating current.

The Binary output settings are for setting the outputs between normally open (NO) and normally closed (NC). You can
change the descriptions of both inputs and outputs; this helps you differentiate the various signals from one another when
making configurations.

LED settings
In the LED settings you can change the descriptions of the user LEDs. Additionally, you can set the color of the LEDs (green
or yellow) when configuring MVR-210 series units. In MVR-250 series units the color of the LED is chosen when you connect
signals to the LEDs in the matrix. The color priority defines which color is lit up if two or three colors are activated for the
same LED.
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Device I/O matrix
The Device I/O matrix tab displays the full I/O matrix of the device. Any I/O connections made to any of the functions can
also be seen here. Additionally, whenever connections are made in the I/O matrix table, the changes can be seen in the
function's I/O matrix table Protection > [Function] I/O tab. When the Live Edit mode is on, the status of an active signal is
displayed with a green line.

When changes are made to the Device I/O matrix, the logic in the device is no longer up to date. The logic needs to be
updated into the relay with Commands > Write to relay for the changes take effect. The available output signals vary
depending on the device type.

The matrix has two kinds of connections for output contacts: Connected and Connected and latched. The connected
output is activated or released, when the input is activated or released. Similarly, the latched connection output signal is
activated when the input is activated; however, the output remains active until it is cleared manually from the device's panel
by pressing the Back button. A latched signal can also be reset remote terminal unit.

Click on the crossing point of an input signal and an output signal to make a connection. Then choose None, Connect, or
Latch.

When configuring an MVR-21x series device LED assignments, you can set the color of the LED with Control > Device I/O >
LED settings. In MVR-25x series devices you can choose the color of the LED when making the matrix connection. The
available colors are green, red and orange. If two or more signals are attempting to activate different colors to the same
LED, the displayed color depends on the priority set in Control > Device I/O > LED settings.
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5.5 Communication menu

5.5.1 Communication menu

The Communication menu is used for setting up the basic settings for connecting to unit with setting tool and RTUs.

5.5.2 Connections

The Connections tab consists of the Ethernet IP address settings and the RS-485 serial communication settings, both
located in the back panel.

Ethernet
The Ethernet IP address settings define what IP address the Ethernet port uses. If an Ethernet-based communication
protocol is used, this IP address is used for that as well. Additionally, this section displays the device's MAC address. You
can enable Ethernet-based communication protocols, such as IEC 61850, Modbus TCP, and more at Communications >
Protocols.

Serial COMx
In this section you can define the basic settings used by serial communication ports. You can select the serial
communication protocol if one is used by this port. Further communication protocol settings can be done at
Communications > Protocols.

5.5.3 Protocols

This tab mostly consists of communication protocol enabling, slave addresses, measurement intervals etc. Available
settings depend on the communication protocol.

NTP
If NTP time synchronization is used, the server and client settings are defined here. To use time synchronization with NTP,
the Timesync. source parameter in the General menu should be set to External NTP. When the device time is
synchronized, the NTP quality for events parameter in this tab changes from Not synchronized to Synchronized.

IEC 61850/GOOSE
This tab is used as a starting point for configuring IEC 61850 settings. The settings include the enabling of IEC 61850
and/or GOOSE subscription, GOOSE input settings and measurement dead bands. After these have been set up, further
settings can be made in the DEIF MVR USW main toolbar with Tools > Communication > IEC 61850.

Modbus/TCP
In this tab you can only enable the Modbus/TCP protocol and define the IP port for the communication. All further settings
can be made in the DEIF MVR USW main toolbar with Tools > Communication > Modbus map.

Modbus/RTU
In this tab you can only set up the Modbus/RTU slave address. You can enable the Serial Modbus/RTU at Communication >
Connections. All further settings can be made in the DEIF MVR USW main toolbar with Communication > Modbus map.

IEC 103
In this tab you can only set up the slave address and the measurement update interval. You can enable the IEC 103 protocol
at Communication > Connections. All further settings can be made in the DEIF MVR USW main toolbar with Tools >
Communication > IEC 103.

IEC 101/104
The standards IEC 60870-5-101 and IEC 60870-5-104 are closely related, as both are derived from the IEC 60870-5
standard. On the physical layer IEC 101 uses serial communication, whereas IEC 104 uses Ethernet communication. If the
IEC 101 protocol is used, it can be activated at Communication > Connections. If the IEC 104 protocol is used, it can be
activated at Communication > Protocols > IEC 101/104. Both IEC 101 and IEC 104 share the measurement dead band
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settings and the scaling coefficients. All further settings can be made in the DEIF MVR USW main toolbar with Tools >
Communication > IEC101/IEC104 Map.

SPA
In this tab you can only set up the SPA address and choose whether or not time synchronization is used. You can enable
SPA at Communication > Connections. The SPA map can be found at Tools > Communication > SPA map through the
DEIF MVR USW main toolbar. The SPA event list can be found at Tools > Events and logs > Event list.

DNP3
DNP3 is supported in both the serial mode and the TCP (Ethernet) mode. To use DPN3 in the serial mode, it must be
activated at Communication > Connections. If DNP3 is used in the TCP mode, it must be activated at Communication >
Protocols > DNP3. Further settings can be found at Tools > Communication > DNP.

Modbus I/O
The Modbus I/O tab is used for RTD and mA measurements with external ADAM modules connected to the RS-485 port.
Using ADAM modules requires that the Modbus I/O protocol is selected at Communication > Connections.

5.5.4 General I/O

The General I/O tab has 12 fault registers that can be set up to record the following signals:
• I>, I>>, I>>> and I>>>> (non-directional over-current) fault values of each phase individually
• Io>, Io>>, Io>>> and Io>>>> (non-directional earth fault) residual current values
• Id>, Id>>, Id>>> and Id>>>> (directional over-current) fault values of each phase individually
• Iod>, Iod>>, Iod>>> and Iod>>>> (directional earth fault) residual current values
• FLX (fault locator) value

Each of these can be set to be triggered by the TRIP signal, by the START signal, or by both START and TRIP signals. These
registers can be read through SCADA for fault analyzing.

5.5.5 Real-time signals to communication

If a measurement is not available in the communication protocol signal list, it can be added manually in this menu. There are
8 channels available in this function. The measurements are categorized under Currents, Voltages, Powers, Impedance
(ZRX) and admittance (YGB) and Others.

For example, if the ninth harmonic of IL2 current measurement needs to be reported to SCADA, simply set the magnitude of
one of the channels as Currents and IL2 9.h. After setup this function reports these measurements to SCADA.

5.6 Measurement menu

The Measurement menu is used for setting up current and voltage transformer scaling and for observing different
measurements and phasors. The following lists all possible measurement options; which of them are available to use
depends on the device type in use.
• Transformers (CT & VT)
• Frequency
• RTD and mA inputs
• RTD
• AI (mA, DI volt) scaling
• Current measurement
• Current component measurement
• Voltage measurement
• Power and energy measurements
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• Impedance calculations
• Admittance calculations
• Phasors
• Programmable stages

Thel tab Measurements update allows for the setting of the update interval of various measurements.

More information
See the Designer's handbook for more information about measurements.

CT module
The CT module tab is for setting up the current transformers' primary and secondary nominal currents as well as the
polarities of the channels. By default, the per unit value of current-based protection functions is scaled from the current
transformers' primary nominal current. The nominal current value can also be set by selecting the Object In p.u. option for
Scale meas. to In and then giving a current value to Nominal current In.

VT module
The VT module tab is used to set up the nominal values of voltage transformers. The only difference to current transformer
settings is that you can choose from three different measurement modes (3LN+U4, 3LL+U4, or 2LL+U3+U4. Depending on
which measurement mode is chosen, you can activate U3, U4 or both channels for residual voltage measurement or for
synchro-checking. You can also activate voltage memory in this tab.

User manual 4189341238C UK Page 25 of 82



Frequency
In the Frequency tab you select the sampling mode which determines which frequency setting is used in calculations.
• Fixed: The calculations that need frequency are based on the value given in the Sys. nom. f. (the system nominal

frequency) parameter; by default it is 50 Hz.
• Tracking: The frequency will be tracked by referencing the chosen channels in f. Refx (the frequency reference x).

5.7 Monitoring menu

Enabling and setting monitoring functions
The enabling and setting of monitoring functions is done the same way as with control functions and protection functions.
The Monitors enabled tab lists the monitoring functions that the relay in question has and with the drop-down menu you
can activate them at will. In the Monitor functions tab you can select a monitoring function and view its information and
edit its settings.
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Disturbance recorder
The parameter settings for the disturbance recording are done in Monitoring > Disturbance REC. When the disturbance
recorder has been configured, the Recorder Control section displays the following: the maximum number of recordings that
can be recorded into the memory, the maximum length of a recording, the maximum length of a pre-trigger recording as
well as the recordings currently in memory.

The table below presents some examples of how many recordings fit into a relay' s memory with different settings.

Example 1 Example 2 Example 3

Samples per cycle 64 64 64 

Analogue channels 8 8 8 

Digital channels 24 24 24 

Recording length* 5 s 10 s 60 s 

Total number of recordings 100 52 8 

*NOTE: The Recording length value must not exceed the Max. length of recording value.

In this example the Disturbance recorder records 64 samples per cycle from the chosen nine analogue channels (IL1, IL2,
IL3, I01C, I01F, UL1, UL2, UL3, U0). It also records the state of the four chosen digital channels (I>START, I>TRIP, I>
BLOCKED and Ih> START).
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If there is a disturbance recording in the memory, you can retrieve it by clicking Disturbance recorder on the DEIF MVR
USW main toolbar and select Get DR file from the drop-down menu. This loads the DR file as a .zip file to the folder you
have set for disturbance recordings in Tools > Settings. If Auto. get recording has been enabled, the recordings are sent to
the FTP server; from there the recordings can be loaded with SCADA.

Any disturbance recording file in COMTRADE format can be evaluated with the DEIF MVR USW software. Open the
Disturbance recorder on the main toolbar and select Launch MVR USW from the drop-down menu.

When uploading disturbance recorder parameters and logic changes to the relay, you also need to write the disturbance
recorder settings with Commands > Write to relay.

Device diagnostics
Name Range Step Default Description

Diagnostic alarm status 

0: Temp. out of range
1: Voltage out of range
2:HW configuration invalid
3: Relay output failure
4 to 9: Option card A toF alarm
10. GOOSE invalid

- - Displays the status of the diagnostic
alarm. 

Clear diagnostic alarm 0: -
1: Clear - 0: - Clears the diagnostic alarms. 

Protection constants
calculated 

0: Not calculated
1: Calculated - - Indicates whether or not protection

constants are calculated. 
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Name Range Step Default Description

Internal temperature 0.0 to 200.0 °C 0.1 °C - Displays the internal temperature of the
device. 

Internal voltage (24
V/24 C max/24 V
min/24 V deviation) 

0.0 to 50.0 V 0.1 V - 
Displays the internal voltage of the
device: the nominal, the maximum, the
minimum, and the deviation. 

Full system reset 0: -
1: Reset - 0: - Resets the whole system of an MVR-200

series device. 

Protection system
reset 

0: -
1: Reset - 0: - Resets the protection system. 

Reset is pending 0.0 to 60.0 s 0.1 s - 

When a full system reset or a protection
system reset command has been given, a
countdown start. When the countdown
reaches zero, the MVR-200 series device
resets. 

Baseboard card
revision 0 to 232 – 1 1 - Displays the revision of baseboard card. 

Baseboard card serial
number 0×0 to 0×FFFFFFFF 0×1 - Displays the serial number of the

baseboard card. 

CPU serial number 0×0 to 0×FFFFFFFF 0×1 - 

Displays the serial number of the device's
CPU. You can have up to four CPUs; the
serial number of each is displayed on its
own row. 

Slot x card type 

0: Reserved
1: Display
2: Current measurement
3: Voltage measurement
4: Digital input
5: Output relay
6: Arc
7: Communication
8: mA output
9: mA input
10: RTD input
11: Low energy analogue
12: Digital input
13: U0 measurement
14: LC Ethernet
15: RJ 45 Ethernet
16: ST Ethernet

- 0: Reserved Displays the card type of the selected slot
(A to N). 

Slot x card revision 0 to 232 – 1 1 - Displays the card revision of the selected
slot (A to N). 

Slot x card serial
number 0×0 to 0×FFFFFFFF 0×1 - Displays the card serial number of the

selected slot (A to N). 

Internal relay fault
status 

0: Storage error
1: Logic file missing
2: Acquisition unit error
3: Measurement config error
4: Relay hardware setup error
5: System overload error
6: Not configured yet
7: Firmware upgrade done
8:Slot supervision error
9: Software inconsistency error
10: Safe setting mode active

- - Displays the internal relay fault status of
the device. 

User manual 4189341238C UK Page 29 of 82



Name Range Step Default Description

Clear fault status 0: -
1: Clear - 0: - Clears the internal relay fault status. 

Option card health
status 

0: Baseboard fault
1: Card slot A fault
2: Card slot B fault
3: Card slot C fault
4: Card slot D fault
5: Card slot E fault
6: Card slot F fault

- - Indicates if fault on any of the cards have
been detected. 

Logic state 

0: Setup
1: Stopped
2: Running
3: Error

- - Indicates the status of logic. 

Gates usage 0.0 to 100.0 0.1 - Displays the amount of available logic
gates used in percentage value. 

Wires usage 0.0 to 100.0 0.1 - Displays the amount of logic wires used in
percentage value. 
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6. Commands menu

6.1 Time settings

Selecting time zone
You can select a time zone for the relay:
• Click Commands in the tool bar.
• Select Set time zone from the drop-down menu.

Synchronising time
If there is no time synchronisation source you can synchronise the relay time with the PC time:
• Click Commands in the tool bar.
• Select Sync time from the drop-down menu.

Alternatively, you can choose to synchronise the relay and PC times when you upload configurations to the relay by
checking the Sync time box.

6.2 Uploading language files

The MVR-200 series includes five languages:
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• English
• Finnish
• French
• Russian
• Spanish

However, a customized language file can be uploaded to the relay. Click Commands on the toolbar and select Load
language from the drop-down menu.

This opens a file dialogue which allows you to upload the desired language file to the relay.

6.3 Set timers

You can set timer signals to help control setting groups and other logic components which activate and deactivate at
certain intervals.
• Click Commands in the toolbar
• Select Set timers from the drop-down menu.

Click on the  icon at the top right of the window to add a new timer configuration line. Then select one of the displayed
timers, and set its state to switch to 1 or 0 at a specific time. The calendar view shows when a specific timer is on. Each
timer has its own color code, which is displayed at the top of the window above the timer configuration line.

In the example, the state of the selected timer is 1 (the timer is on), when a day's box is red. The red circle marks the
current day, which in this example is November 13th. Click on a day to see a more detailed division of the day below the
calendar at the bottom of the window. Once the timers have been configured, you can send the configurations to the relay
by clicking the Set button on the top right of the window. This requires an active connection to the relay.

User manual 4189341238C UK Page 32 of 82



6.4 User levels and passwords

There are four user levels:
• Super user = Full access, including configurations.
• Configurator = Access to all settings.
• Operator = Access to limited settings and controls.
• User = Only view access.

Each user level is represented by a specific lock icon in the HMI.

Setting up user levels in your local HMI
The factory default is that all user levels are open in the device. To activate and lock various user levels:
• Push the Lock button in the device's HMI.
• Choose the key icon for the user level.
• Set the desired passwords for the different user levels.

The key icon next to the user level allows you to set a new password for that level. Any user level with a password can be
locked by pressing the Enter key while the lock is selected. If you need to change the password, select the key icon again
and give the new password. If you want to disable password for a user level, set password to 0.

Unlocking and locking a user level generates a time-stamped event to the event log. A user level with a password
automatically locks after 30 minutes of inactivity.

NOTE To change a password the user level in question must be unlocked.

Accessing user levels in DEIF MVR USW
After you have activated the passwords, DEIF MVR USW requires your login information. Click Commands on the toolbar
and select Login from the drop-down menu.
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This makes the Access levels pop-up window appear.

Each level requires its own password to open it. When a user level is opened, an event is recorded to the relay's event
history.

At the top of the DEIF MVR USW window, next to the Live Edit mode box, there are a number of yellow stars.

They indicate the active user level:
• Three yellow stars = Super user
• Two yellow stars = Configurator level
• One yellow star = Operator level
• All grey stars = User level

6.5 Clearing Event buffer

You can clear the event history by clicking Commands on the toolbar and selecting Clear Event buffer. This clears the
event history and places an Event buffer clear marker in the event history.

6.6 Reconfiguring communication settings

When you upload new communication IP settings to the relay, a prompt appears asking whether these settings will be
adopted to use immediately.

• Select Yes: The relay is configured with the new settings.
• Select No: The relay is not configured with the new settings, until you open Commands > Reconf communication

settings and select Yes. If the relay is rebooted before the reconfiguration is finished, it will revert back to original IP
address.
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6.7 Safe Settings mode

You can toggle the Safe Settings mode:
• Connect to a relay.
• Click Commands on the DEIF MVR USW main toolbar.
• Select Toggle Safe Settings mode from the drop-down menu.

When in this mode, you can perform tests without causing the relay to actually control any of the output contacts. Events
are still triggered normally.

Turning the Safe Settings mode on causes the relay to give a backup .aqs file. This backup has the current relay settings. If
the new settings fail the test and you need the old setting back, you can use this backup .aqs file to retrieve them. The file
also includes the event history dialogue. This dialogue can be used to see whether or not the test was successful.

When the Safe Settings mode is activated, a red SAFE MODE label appears on the main toolbar.

When this mode is active, the HMI display of the device displays a skull at the top of the display and of the IRF output
contact; the device's ERROR LED is activated.

You can disable the Safe Settings mode by clicking Commands > Toggle Safe Settings mode again.
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7. Tools menu

7.1 Tools menu

7.2 Running scripts

Occasionally scripts need to be run to the relays. For example, you may need to run a script when you have changed the
hardware configurations after installing a new card. You can do this by clicking Tools on the DEIF MVR USW main toolbar
and selecting Run script from the drop-down menu.

Disabling the firewall is recommended when running a script because the firewall may cause the script to fail. All scripts are
provided by DEIF.

7.3 Mimic editor (MVR-210 series)

The Mimic editor is used to create a visualization of the protected system for the HMI. In this chapter we are going to take a
look at the simple tools DEIF MVR USW has for making a mimic display for the MVR-210 series units.
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The mimic display is a 9×6 grid, which can be edited individually. The selectable items in the Mimic editor library include:
• Lines and icons for drawing purposes.
• Objects and indicators to visualize the state of breakers and disconnectors, configured in the Objects tab of the Control

menu.
• Programmable control switches which can control logic, setting groups, etc.

The grid can be cleared by clicking the Clear button.

Adding symbols and objects
Click on one of the boxes in the grid and an Object menu appears. Select the item you want to use from the Select item
drop-down menu. The frame on the right shows what the item looks like.

Adding measurements
You can add measurements into the mimic by using the drop-down menus on the right side of the HMI designer. The HMI
display can use up to 10 different measurements. The text boxes are used to describe what the measurements represent.
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You can move the measurements by using the spin boxes to the right of the Position (X,Y) text. Changing the number of
rows also changes how many measurements can be shown in the mimic. Each row fits two measurements.

Adding programmable mimic indicators
Programmable mimic indicators can display texts which indicate the status of the network. In the example, the I0>
BLOCKED signal has been assigned to the Mimic indication status 1 through Control > Device I/O > Programmable mimic
indication. Then you can choose a box from the Mimic editor grid and select Programmable indicator text from the library.
Before clicking OK type in the texts you want displayed on the screen when the signal is on and when it is off.

Loading the mimic to relay

If you have an active connection to a relay, click the Send to relay button  to send the mimic to the relay.

Exporting the mimic
After you are finished creating the mimic, clicking the Export button makes it a part of the aqs configuration file you are
working on. The export command is automatically executed after some functions, but not after others (such as editing the
measurements text field).
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Saving the mimic as a separate file
The mimic can be saved as a separate file by clicking the Export As.. button. You can import a mimic from these separate
files by pressing the Import from.. button. This is a useful tool especially when there are several relays with similar custom
mimics. You can also use the Export and Import buttons to copy the same mimic to other .aqs files.

7.4 Mimic editor (MVR-250 series)

The Mimic editor is used to create a visualization of the protected system for the HMI. This chapter is about the tools DEIF
MVR USW has for making a mimic display for MVR-250 series units. MVR-250 series devices can store up to 5 mimics.

The image and table below present the functions available to you in the Mimic editor's main toolbar.

(#) Button Description

1. Mimic drop-down menu Chooses which of the five available mimics is being worked on. 

2. New Empties the mimic sheet. 

3. Reload Reloads a previously saved version of the mimic. 

4. Save Saves the mimic to the currently open .aqs file. 

5. Open Opens a mimic file. 

6. Save as… Saves the mimic file as a separate file. 

7. Send to relay Sends the currently open mimic to the relay if there is a connection is to the relay. 

8. Last loaded slot Indicates the slot to which the mimic has been loaded. 

User manual 4189341238C UK Page 39 of 82



(#) Button Description

9. Use grid If the grid is in use, items in the mimic editor move by the number of pixels defined in Grid
size.

10. Grid size Defines the number of pixels items move each step if Use grid is enabled.

Adding and removing items
You can add items to the mimic by right-clicking somewhere on the mimic sheet and selecting Add item from the menu that
appears. By clicking the From library button on the right, you get a pop-up window with the various item types that are
already in the library. Double-click an item to import it to the mimic, or select an item and press the Import button. You can
resize the items and move them on the mimic grid. You can also add a selected item to a library with the item name as its
title with the Add to library button. An item that has been added to a library can then be used again by choosing it from the
list by clicking From library.

You can also remove items from the mimic: right-click on an item on the mimic and select Remove item from the menu that
appears next to the cursor. Alternatively, you can select the to-be-deleted item from the list at the top-right window, right-
click it and select Delete from the menu.

Item management
You can move an item to the front and back one step at a time with the Up and Down buttons. The item at the top of the list
is in the front and the item in the bottom of the list is the furthest back. This is relevant when the Mimic editor decides
which image to display in an item with multiple images.

You can also rename the item by double-clicking it on the list. Right-clicking an item brings up more options for moving and
deleting it.
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Function control item
You can select between 4 function controls; only one can be selected at any one time.
• Toggle allows you to control logical inputs ON (1) and OFF (0) with the selected item.
• Control object lists the available objects that can be controlled with the item.
• Step controls the functions related to Generator commander.
• Write object (I/O) controls objects such as the voltage regulator with up and down commands.

Item images and visibility conditions
An item can contain one or more images. Each image can then be assigned with one or more visibility conditions with Add
image condition. If no visibility condition is assigned, the image is always displayed. If two images are visible in the same
item at the same time, the image that is at the top of the list is displayed. If multiple visibility conditions are applied, all
conditions must be met for the image to be displayed.

In the example, the image CBopen.png is visible, if the parameter Object type is set to Circuit breaker and its status (as in
the parameter Object2 Break) is Open.

The Change image button allows you to change the image while retaining the image conditions of the image being
replaced. The new image is applied with the original resolution. You can resize it and other images by changing the
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resolution number located next to the Resize all button; if that button is active, you resize all the images in the item at the
same time.

An item can contain one or more texts. Each text can then be assigned with one or more visibility conditions. If no visibility
condition is assigned, the text is always displayed. If two texts are visible in the same item at the same time, the text at the
top of the list is displayed. If multiple visibility conditions are applied, all conditions must be met for the text to be displayed.

The image above shows the various text settings available in the Mimic editor. The default font size for texts added to items
is 12; however, you can resize the font with the number box. You can also move the text's position inside the item with the
two number boxes: the left box moves the texts horizontally, the right box vertically. Additionally, you can add and remove
text conditions with their respective buttons. You can also change the color of the text with the multicolored circle with A,
and the color of the text's background with the other multicolored circle.

There are six ways to select a color for text or its background:
1. From the collection of basic colors.
2. From the color gradient grid and brightness slider.
3. Move the cursor to any point on the screen and click to use that specific color.
4. From the collection of saved custom colors.
5. Edit the red, green and blue integers as well as the hue, saturation and brightness individually.
6. Enter the color's HTML code.
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In addition to these settings, the Alpha channel number box sets the transparency of the text or of the text background (0
= fully transparent, 255 = fully visible).

The same item can be applied with both images and texts. For example, you can have the component's abbreviation Q0
next to the image.

Adding measurements to the mimic view
You can add measurements by right-clicking the mimic sheet and selecting Add measurements from the menu that
appears. The following setting selection appears on the right side of the Mimic editor window.
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The plus (+) button adds a new row to the measurement item. You can add a prefix to any measurement row by right-
clicking its slot below Measurement text. From the Measurement parameter drop-down menus you can define which
measurement is shown in the mimic. Additionally, you can change the font size, the text color, and the text's background
color in the same way as in text settings. Measurement text is a user defined prefix for the measurement.

The measurement can be assigned with one or more visibility conditions. If no visibility condition is assigned, the
measurement is always displayed. If multiple visibility conditions are applied, all conditions must be met for the
measurement to be displayed.

7.5 Logic editor (MVR-210 series)

Select the Logic editor under Tools.

Logic editor has the tools that are most common for logic programming. The function blocks consist of the following
common logic gates: AND, OR, XOR, NOR, NOT, Connect, SR latch, D flip-flop,Counter and Delay. Additionally, there is also
the Latch gate which works the same way as a normal SR latch gate but it can only be reset with the Back button located in
the HMI.

The image shows an example where the NOT and AND gates are ON (the wires are green), and the DI7 Q0 Open input is ON
(the text is green). If the Live Edit mode is activated, you can observe the status of each signal in real time.

The logic is updated every 5 ms in the relay. Fast events might be not seen in the Live Edit mode. For reliable event
activation and de-activation, analysis use of event recording and disturbance recordings is recommended instead.

The logic must be designed from left to right. The logic gate operation that must be done first must be furthest to the left
on the canvas. If the order is important, make sure one is not placed right below another.

While very large and complex logics can be made with the logic editor, the number of logic gates and wires that can be
placed is limited. The maximum number of gates is 768, and for wires the maximum is 256. The number of wires currently
used is displayed as a percentage value at Monitoring > Device diagnostics in the parameters Gates usage and Wires
usage. These parameters will update only after the logic has been loaded to the relay.
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Logic editor command buttons

Logic editor has the following command buttons on its main toolbar:

Command button Description

Save Saves the logic to the .aqs file that is currently open. 

Reload Loads back the logic that is in use in the .aqs file that is currently open. 

Clear Clears the logic sheet. 

Export Saves the logic as an .aql file that can then be opened in another .aqs file. It also functions as backup
save of the logic. 

Load Opens any .aql logic file. 

Export script Saves only the script of the logic. Mostly used by DEIF personnel for troubleshooting purposes. 

Writing a new logic to the relay
Even in Live edit mode, a certain sequence has to be followed to make a new logic work:
1. Press the Logic Save button.
2. Go to Commands and select Write to Relay.

•
3. Write Logic to relay.

•
4. The new logic is now operational.

Adding and removing logic gates, inputs and outputs
You can add a logic gate to the table by double-clicking on the table, selecting the wanted logic gate from the pop-up
window, and then clicking the OK button or by double-clicking the selected gate.
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Similarly, you can add input signals and output signals by double-clicking on the table, selecting the wanted signal from the
pop-up window, and then clicking the OK button or by double-clicking the selected signal. To choose the specific signal for
your inputs and outputs, double-click the I/O symbol on the table and select the wanted signal from the pop-up window.

You can filter the signal with the search box. For example, typing trip to the search box lists all signals that contain the word
trip. The editor does not differentiate between upper and lower case.

If you want to remove a gate, you can click it (making it red) and then press Delete. If there are multiple items on the logic
sheet you want to delete simultaneously, paint the area with your mouse (making all components within that area red) and
then press Delete. Painted logic can also be moved around and copied (Ctrl + C) and pasted (Ctrl + V).

Drawing lines
When you hover the mouse over an input or output pin, a blue box appears. Click the box, move the mouse to the
destination and click on the box that appears.
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Latch gate

When a Latch gate receives a rising signal, its output remains active until the signal is cleared. You can clear the signal by
pushing the Back button on the relay's front panel.

Connect gate

The Connect gate has two applications. The first, and the simplest, application is using the gate to connect a it directly from
an input to an output.

The Connect gate is also used if an output of a logic gate needs to be connected to two outputs. This is because MVR-210
series units do not support connecting the same signal to two outputs without a gate between them, and DEIF MVR USW
does not let you make that kind of connections, see the image below on the left. In the image below on the right shows a
correct way to connect two outputs to a logic gate.

However, you can always connect a signal to a single output without a Connect gate.
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SR latch gate

The SR latch gate sets the output value to 1, when the S value is 1. The output value remains at 1 (even if the S value goes
back to 0) until the R value is set to 1.

D flip-flop gate

The D flip-flop gate captures the D input value every time the clock rises and then forwards the D input value to the output
(Q).

The truth table of the D flip-flop gate:

Input Output

Clock D Q

Rising 0 0 

Rising 1 1 

Non-rising 0 Q 

Counter gate

The Counter gate adds 1 to the counter value every time the value of the CNT signal goes to 1. When the counter value is
equal to or higher than the trigger value, the output is set to 1. The R signal resets the counter to 0.

Delay gate
The Delay gate is able to delay the high or low value of the output signal. When you double-click on the gate, you can set
the high (H) and low (L) values (in milliseconds). After you have made the wanted changes, click Set and upload the
settings to the relay. There can be up to sixteen Delay gates in use at any one time.

The image shows an example where the Delay gate has been used to delay the signal from the input for 1.5 seconds before
it is sent to the output.
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Edge gate
The Edge gate produces a 5 ms pulse when the D input receives a rising or a falling signal, depending on the R/F input's
logic. If the R/F input is active, the output generates a pulse from a rising input signal. If the R/F input is not active, the
output generate a pulse from falling edge.

If you need a pulse longer than 5 ms, you can extend the pulse with the delay gate. In the example the Delay gate has 0 s of
high delay and 5 s of low delay, resulting in a five-second pulse.

If the gate is only going to be used in the rising or falling edge mode, the easiest method to define that mode is to connect
an Always true or an Always false signal to the R/F input.

Notes

Notes can be used for describing logic programs for easier understanding. You add a note by double-clicking the editor
table and selecting Note from the pop-up window menu. You can start writing on the note by clicking the note's bottom
row. You can also edit the note later by clicking the existing text.

7.6 Logic editor (MVR-250 series)

Logic editor has the tools that are most common for logic programming. The function blocks consist of the following
common logic gates and circuits: Input, Output, Analogue input, Analogue comparator, AND, OR, XOR, NOR, NOT, Connect,
SR latch, D flip-flop, Counter, Delay, and Edge. Additionally, there is also the Latch circuit which works the same way as a
normal SR latch circuit but it can only be reset with the Back button located in the HMI.

Logic editor command buttons

Logic editor has the following command buttons on its main toolbar:
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Command button Description

Save Saves the logic to the .aqs file that is currently open. 

Reload Loads back the logic that is in use in the .aqs file that is currently open. 

Clear Clears the logic sheet. 

Export Saves the logic as an .aql file that can then be opened in another .aqs file. It also functions as backup
save of the logic. 

Load Opens any .aql logic file. 

Export script Saves only the script of the logic. Mostly used by DEIF personnel for troubleshooting purposes. 

MVR-250 series logics can be divided into multiple logic sheets. To add a new sheet, click on the Plus button or press Ctrl
+T.

These logic sheets can be renamed by double-clicking on the name. You can remove a logic sheet by clicking on the 
button in the top right corner of the sheet name box. The button only appears when the cursor is on top of it.

The logic is updated every 5 ms in the relay. Fast events might not be seen in the Live Edit mode. For reliable event
activation and de-activation, analysis use of event recording and disturbance recordings is recommended instead.

The logic must be designed from left to right. The logic gate operation to be done first must be furthest to the left on the
canvas. If the order is important, make sure one is not placed right below another.

While very large and complex logics can be made with the logic editor, the number of logic gates and wires is limited. The
maximum number of gates is 768, and for wires the maximum is 256. The number of wires is currently displayed as a
percentage value at Monitoring > Device diagnostics in the parameters Gates usage and Wires usage. These parameters
will update only after the logic has been loaded to the relay.

Writing a new logic to the relay
Even in Live Edit mode, a certain sequence has to be followed to make a new logic work:
1. Press the Logic Save button.
2. Go to Commands and select Write to Relay.

•
3. Write Logic to the relay.
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•
4. The new logic is now operational.

Logic gates
MVR-250 series units have the same logic gates available as MVR-210, see Tools menu, Logic editor (MVR-210 series) in
this document. In addition, MVR-250 series logic editor also have analogue input and comparator gates.

The analogue comparator can be used to activate or disable the gate output based on the measurement selected to the
analogue input. When adding the analogue comparator to your logic, double-click on the gate to open a pop-up window,
where you can select the operator mode and the comparator value.

In the example, the analogue input 3PH active power (P MW) is connected to the analogue comparator gate, where the
value has been set to 10 and the operator mode is <. This means that the analogue comparator output gate is active
whenever the three-phase active power is under 10 MW.

The analogue comparator gate has six different operator modes:

Operator Description

== Equal to 

!== Not equal to 

< Less than 

> Greater than 

<= Less than or equal to 

>= Greater than or equal to 

Adding inputs, outputs and logic gates
You can add a logic gate to the table by double-clicking on the table, selecting the wanted logic gate from the pop-up
window, and then clicking the OK button or by double-clicking the selected gate.
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Similarly, you can add input signals and output signals by double-clicking on the table, selecting the wanted signal from the
pop-up window, and then clicking the OK button or by double-clicking the selected signal. To choose the specific signal for
your inputs and outputs, double-click the I/O symbol on the table and select the wanted signal from the pop-up window.

You can filter the signal with the search box. For example, typing trip to the search box lists all signals that contain the word
trip. The editor does not differentiate between upper and lower case.

Multiple items in the logic sheet can be chosen to be edited simultaneously by painting the area with the mouse. When
multiple items have been painted, you can move the selected items, delete them with the Delete key, or copy and paste
them with Ctrl+C and Ctrl+V, respectively.
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Drawing lines
When you hover the mouse over an input or output pin, a blue box appears. Click the box, move the mouse to the
destination and click on the box that appears.

You can also connect signals to multiple destinations by repeating the previous steps:
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You can remove connections by clicking on the line and pressing the Delete key. If you want to exit the wiring mode before
connecting two pins, press Esc.

Some logic gates (such as OR gates) can take more than two inputs. This can be done by dragging a line close to the gate's
inputs which makes more inputs appear. You can add up to ten inputs to a single gate.

7.7 Carousel Designer (MVR-210 series)

The number and content of the menus shown on the HMI display can be edited in the Carousel Designer editor when
an .aqs file is open.
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Click on the  button to add a new view. You can select the type of the view from the drop-down menu.

Once the carousel design is done, you can export the design into the .aqs file that is currently open by pressing the Export
button. To save the changes, click File > Save in DEIF MVR USW. You can send the changes to a relay by writing the Mimic
to the relay at Commands > Write to relay. If you have an existing saved Carousel menu, the Import button imports it to the
currently open .aqs file.

Table 7.1 Available Carousel views

View name Description

Mimic Displays the unit's mimic. The mimic view image can be edited at Tools > Mimic editor.

LEDs Displays user defined descriptions of the LEDs. 

Events Lists all of the events recorded by the unit. 

Measurements Displays measurements up to 8 lines. You can edit which measurements are shown at Tools >
Carousel Designer.
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View name Description

Favourites Shows the setting menus favourited by the user. 

Clock Displays the unit's time and date. The time and the date can also be set here. 

Fault register Displays the fault values recorded by the VREC function (not available in all MVR-210 series device
types). 

Alarms Displays the activated alarms (available only in MVR-214). 

7.8 Carousel Designer (MVR-250 series)

The number and content of the menus shown on the HMI display can be edited in the Carousel Designer editor when
an .aqs file is open.

Click on the  button to add a new view. You can select the type of the view from the drop-down menu.
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If there is more than one view on a page, the size of the view box can be changed with the thick white bar between the
views. You can add and remove pages with the Add page and Remove page buttons. The order of the pages is determined
by their position in the list on the left of the Carousel Designer window. Once the Carousel design is done, you can export

the design to the .aqs file that is currently open by pressing the Save button . You can send the changes to the relay by

pressing the Send to relay button , or by the writing Mimic to the relay at Commands > Write to relay.

7.9 Project editor

Project editor is a project management tool. You can create a new project by clicking the New project button, creating a
node called Project. You can change the node name by double-clicking it.

If you right-click a node, a context menu appears. Selecting Add substation from this menu add a substation to the node.
You can add bays to a substation by right-clicking a substation node and selecting Add bay from the context menu.

Clicking on a bay node enables the menu on the right side of the node tree view. In this menu you can assign a setting file
to the selected bay. The ... button opens a file dialogue where you can select an .aqs file. Click the Apply button to assign
the selected .aqs file to the selected bay. Once a setting file has been assigned, it can be opened by clicking the Open .aqs
button. You can save a project by clicking the Save project button. A saved project can be opened by clicking the Open
project button.

7.10 Wizard

The Wizard tool is integrated in the DEIF MVR USW configuration and setting tool. Wizards can be used to generate settings
to transformer protection relays.

The main benefits of the Wizards are:
• Easy to install and use (integrated in DEIF MVR USW).
• Built-in user manual.
• Easy to write differential and REF settings to a relay.
• Direct feedback from the installation.

Transformer wizard
The Transformer wizard uses a selection of transformer-related information and other settings (such as CT specification
and wiring) as the basis for building suitable setting parameters to the relay.
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Generator wizard
The Generator wizard uses a selection of generator-related information and other settings (such as CT specification and
wiring) as the basis for building suitable setting parameters to the relay.
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7.11 Events and logs

7.11.1 Event history

The Event history window displays the time-stamped events. These can for example be pick-ups, trips, or blocks. You can
find more information about event masks in the selected function's Events tab

Event masks determine what is recorded in the event history. They are configured in each function's individual settings in
the Protection, Control and Monitoring menus. The event history can be exported as a separate text file (.txt) by clicking

the Save button .

When you click the Show new events only button, DEIF MVR USW shows only those events that happen from that point on.
Clicking the Show all events button switches back to the view that shows all events.

If you want to see the time difference between two events, right-click on an event and select Add to compare [x] from the
context menu.
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Event lists can also be filtered to show specific events. This filtering is done by writing in the text box at the bottom of the
window. Below is an example where TRIP ON has been written in the text box to only display events that contain the text
TRIP ON.

The tool does not differentiate between lower and upper case: writing trip on, Trip on or tRiP oN all bring up the same
events in the example.

7.11.2 Event list

You can access a list of all possible events by opening the Event List from the Tools menu. Each event has a SPA event

channel. This list can also be saved as a text file by clicking the Save button .
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7.11.3 Configuration change log

The Configuration change log can be used to observe parameter changes made to the relay.

7.11.4 Set alarm events

Alarm events can be set by using the Set alarms dialogue. You can select which events cause alarms in the relay by
checking the respective boxes in the Set alarms window and then pressing the Set button.

User manual 4189341238C UK Page 61 of 82



When one of the alarm events occurs, it is shown in the relay’s mimic view. The newest alarm is always displayed, and it can
be cleared with the HMI's Back button.

Up to 5 alarm events can be stored at any one time. When all five slots are full, the oldest alarm is deleted to make way for
new alarms.

If the auto-recloser is in use, checking the AR Timer box enables a timer that displays the remaining dead time or reset
time.

NOTE • The mimic view must be enabled in the Carousel designer.
• The event that is to be recorded must also be activated in the event mask of the function in question.
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7.12 Communication

7.12.1 IEC 61850

This editor is used for configuring the device's IEC 61850 communication protocol. You can add, remove and edit data sets,
decide which object control model to use, and edit GOOSE publishing, among other things. You can also view the current
IEC 61850 setup and browse the 61850 tree to see the full list of available logical nodes.

Contact DEIF for a complete list of IEC61850 signals.

7.12.2 Modbus map

You can access Modbus information by opening the Modbus map dialogue from the Tools menu. The Modbus map can be

saved as a text file by clicking the Save button .

All signal holding registers in the default map are fixed, which means they cannot be edited by the user. If you need custom
holding registers, you can use the Modbus configurator to change the Modbus map. The Modbus configurator can be found
at Tools > Communication > Modbus configurator.

The fixed holding registers can be also reassigned to user-defined holding registers with the Configure button in the
Modbus map window. This brings up a smaller pop-up window, where you can add a new row by right-clicking and
choosing Add. Then you can key in the holding register you want to use in the new holding register. The holding registers
that users can edit start their numbering from 8001.
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7.12.3 Modbus configurable map

This tool is used to make changes to the register map when communicating using a Modbus protocol.

Available buttons
Button Description

Load old configuration 

Preview 

Export to .txt 

Save to .aqs 

Send to .aqs 

Sort by HR 

Delete HR(s) 

Undo 

Redo 
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Terms
Term Description

Holding register (HR) An object type in Modbus, has Read-Write access, 16 bits in size. 

Default map The static Modbus map that has been used by the relay. 

Configurable map The new Modbus map that can be altered. 

Usage
The default map is not configurable while the configurable map is there for the user to change. If no configuration has been
made, it will be a copy of the default map.

Limitations
The configurable map is set to only hold 10,000 rows at maximum. In each row, the sum of the values in columns HR and
Length cannot exceed 65,535. When one of the limitations is reached, the user is notified and they should undo the latest
action.

Load old configuration
If there are configurations made by the old configuration dialogue, there is a button to import it in the toolbar. The old
configurations are typically imported once when the new configuration dialogue is first used.

If there are configurations made by the new configuration dialogue, the configurations are loaded automatically. The
loading steps are shown in the log section.

Add data
New data can be copied from the default map to the configurable map following these steps:
• Choosing the row(s) needed to be copied in the default map.
• Drag the selected row(s).
• Drop the data onto the configurable map.

The new data is appended to the configurable map.

Change HR
The HR can be changed by double-clicking the HR column of the wanted parameter. You can use the arrow buttons or the
keyboard arrow keys to set the desired HR. Before the HR is changed, if there is another data at that destination, the user is
notified of the conflict and given two choices:
• Yes: Delete the current data at the destination.
• No: Cancel the change.
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Fill HR
This function can be used to change all HRs of multiple consecutive parameters starting from the selected HR.

To fill, first you must select a row. The cursor becomes a cross cursor when moved near the bottom line of the selection
area. While on the cursor, click and drag the mouse to where you want to fill to. While dragging, a tooltip text is shown
containing the resulting HR after the fill. The fill is executed after you release the mouse.

Fill can be done in both directions, up and down.

Similar to when changing the HR value, if the destination of the fill is already occupied, the user is notified of the conflict
and prompted to choose between deleting the occupied data or cancelling the fill.
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Delete HR

HR(s) can simply be deleted by selecting the range to delete and clicking the Delete icon  on the toolbar or press the
Delete key on the keyboard.

The deletion applies to rows only. So, if the row order is HR5-HR10-HR7, deleting HR5-HR10 will not delete HR7.

Change length
The length of data can be changed from 1 to 2 and vice versa. This can be done by double-clicking the row that needed to
be changed in the configurable map. All the rows with HR greater than the selected row will have their HRs changed
accordingly.
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If two changes are made consecutively to a row (1 to 2 and back to 1), no log entry is created.

Sort by HR

The configurable map can be sorted by HR using the Sort by HR icon  on the toolbar. If the map is already sorted, no log
entry is created.
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Preview

A preview of the map can be shown by clicking the Preview icon  on the toolbar.

Export map to text file

The preview map can be exported to a text file using the Export icon  on the toolbar.
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Undo/Redo
Changes made to the configuration map are displayed in the log section and can be undone and redone.

The Undo action can be executed in any of the following ways listed below:
• Using the key combination Control + Z.
• Clicking on the line in the log section.

• Clicking the Undo icon  on the toolbar.

The Redo action can be executed in any of the following ways listed below:
• Using the key combination Control + Y.
• Clicking on the line in the log section.

• Clicking the Redo icon  on the toolbar.

Save and write to the relay

The configuration is saved to the .aqs file after you click the Save icon  on the toolbar.

You can send the configuration to the relay by clicking the Send to relay icon  on the toolbar.

The configuration can also be sent from the DEIF MVR USW menu bar Commands > Write To Relay. Check the Modbus cfg
box in the pop-up window's list and then click the Write button.

If no configuration file exists (for example, if the user have forgotten to save it), there can be errors sending it to the relay.
After sending the configuration file, Modbus must be turned off and on again for the changes to apply.

7.12.4 SPA map

You can access the SPA-related information by opening the SPA map dialogue from the Tools menu. The SPA map can be

saved as a text file with the Save button .
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All SPA events can be found in Tools > Events and registers > Event list.

7.12.5 DNP

You can access the DNP-related information and settings by opening the DNP dialogue from the Tools menu.

When the DNP map is ready, it can be saved as a text file by clicking the DNP map button and then the Save button .

7.12.6 IEC 103

The IEC 103 map editor lists the addresses of the various signals. The user can set the General interrogation (GI) to 0 or 1.
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7.12.7 IEC 101/104

The IEC 101/104 tool displays all signals available with the communication protocols. The user can define both the General
interrogation (GI) and the GI groups for the signals.

7.13 Miscellaneous tools

7.13.1 About Miscellaneous tools

These tools are typically for very specific purposes and are usually not used very often.

7.13.2 Find signal usage

With the Find signal usage tool you can see where a signal is connected in the configuration.
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In this example, the programmable control switch Always True has been chosen. When the Find button is clicked, DEIF
MVR USW displays a list of places where the chosen signal has been used. In this case the Always True is used in logic.
DEIF MVR USW also displays whether or not the signal has been used in matrix, and in the disturbance recorder. Pressing
the Clear Usage button erases all of the connections listed.

NOTE When you clear a signal that has been used in a logic, you are advised to check that the logic is still intact.

7.13.3 Measurement recorder

Specific measurements can be recorded as a text file by using the measurement recorder. In the Measurement recorder
dialogue, you can select the measurements you want to be recorded by checking their respective check boxes.

Activating the measurement recorder requires that there is a connection to a relay and that the Live Edit mode is enabled.
The recording interval can be changed from the drop-down menu of the Interval box (next to the big red circle).With the
Record in selection (located right below the check boxes) you can choose whether the measurements are recorded in DEIF
MVR USW or in the relay itself. If you select Relay, you only need to set the recording interval (from which DEIF MVR USW
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estimates the maximum recording time) and then start recording by pressing the red Record button. If you select DEIF MVR
USW, both the USW and the Live Edit mode need to be activated.

The record file location can be changed by editing the Path field. You can also change the file name in the File name field.
Recording starts when you hit the red Record button. You can stop the recording by hitting the blue Stop button.

NOTE Closing the Measurement recorder dialogue does not stop the recording!

7.13.4 Aqs generator

With the Aqs generator you can generate .aqs files without having a relay to download configuration files from. You only
need a firmware package to generate a configuration file.

When generating a file you have to choose the firmware package, the destination (includes the name for the .aqs package)
and the device type. The generated file can be used for studying and other similar purposes. It is otherwise similar to a file
downloaded from a relay, except it does not have a serial number nor does it display its hardware and software
configurations in the General menu. You can upload the generated configuration to any relay with the same hardware
configuration.

NOTE The DEIF MVR USW may warn about missing mimics, logic and the disturbance recorder if these are not in the
configuration.

7.13.5 Compare files

You can compare .aqs files with the Compare files dialogue. You can select one .aqs file for Open file 1 and another for
Open file 2, and DEIF MVR USW checks for differences in these two files. The basic value differences are shown in the top
half of the list. The latter half shows any differences in the logic, mimic or disturbance recorder files.
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7.13.6 Copy SG settings

You can copy the setting group (SG) settings from one setting group to another setting group with the Copy SG settings
dialogue. This is useful if the settings are very similar between the setting groups in use.

7.13.7 Calibrations

Used for manually calibrating the accuracy of the frequency measurement. MVR-200 units are always delivered with the
frequency measurements calibrated.
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NOTE The calibration of the frequency measurement should only be done by a qualified person who has been instructed
how to do this.

7.13.8 Clear matrix

Clears the matrix portion of a logic file. Affects the connections made at Control > Device I/O > Device I/O matrix. After
clearing the matrix the changes take effect only after loading the logic at the main toolbar (Commands > Write to relay).

7.13.9 Rear panel

The Rear panel dialogue shows the content of the relay's back panel. What you see here depends on the .aqs file that is
currently open.

7.13.10 DI configurator

With the DI configurator tool you can adjust the input activation and release thresholds as well as activation and release
delay times. They can be adjusted to multiple or all inputs at once, which lets you avoid typing the same setting to each
input individually.
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7.13.11 GC-30 configurator

The GC-30 configurator is used in Generator Commander applications to write and read values from the excitation unit.

7.14 FTP

You can open the FTP client by selecting Tools from the DEIF MVR USW main toolbar and then selecting FTP from the drop-
down menu. This opens a dialogue with two views. The one on the left list local directories. The one on the right list server
directories. You can connect to the relay's FTP server by typing in the relay’s IP address in the FTP server field and then
clicking the Connect button.

User manual 4189341238C UK Page 77 of 82



7.15 Device list

The Device list dialogue lists all the available devices connected to the same network as your computer. You can connect to
the selected device by double-clicking it on the list, or by selecting the device from the list and then clicking the Connect
button. Establishing a connection closes the dialogue.

If new devices were connected to the network while viewing the device list, press the Refresh button  to make the new
devices appear on the list.

NOTE • Some switches and firewalls may prevent the DEIF MVR USW from getting this list.
• The device list is not able to list the available devices, if more than one instance of the DEIF MVR USW is open

at the same time.
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8. Exporting and importing settings in a .txt file

8.1 Exporting and importing settings in a .txt file

All parameters, the matrix, and the logic settings can be exported to a single .txt file, which can be edited and imported to
an .aqs file. This can be done with Export settings and Import settings that is found in the main toolbar under File.

Table 8.1 Snipping of exported setting file parameters with I> (over-current) settings

#Id Name Value Unit Min Max Step Description 

24029 NOC1_DT_SET_1 1.160000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24030 NOC1_DT_SET_2 1.160000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24031 NOC1_DT_SET_3 1.160000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24032 NOC1_DT_SET_4 0.040000 s 0.000 1800.000 0.005 Defnite (min) operating time delay 

24033 NOC1_DT_SET_5 0.040000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24034 NOC1_DT_SET_6 0.040000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24035 NOC1_DT_SET_7 0.040000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24036 NOC1_DT_SET_8 0.040000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24037 NOC1_DT_SET_P 0.040000 s 0.000 1800.000 0.005 Definite (min) operating time delay 

24038 NOC1_EVENTMASKHI 0  0 4,29E+09 1 EventMaskHi 

24039 NOC1_EVENTMASKLO 262095  0 4,29E+09 1 EventMaskLo 

24041 NOC1_HARMBLK_1 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24042 NOC1_HARMBLK_2 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24043 NOC1_HARMBLK_3 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24044 NOC1_HARMBLK_4 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24045 NOC1_HARMBLK_5 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24046 NOC1_HARMBLK_6 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24047 NOC1_HARMBLK_7 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

24048 NOC1_HARMBLK_8 0  0 1 1 Inrush Harmonic Blocking (Internal Only
Trip) 

Table 8.2 Snipping of exported setting file parameters with matrix, logic and block connections

#Logic 

#Output Type Input1 

#Matrix script: 

RELE_T1 CONNECT OBJ1_OPENSIGNAL 

RELE_T2 CONNECT OBJ1_CLOSESIGNAL 

RELE_T1 CONNECT NOC1_TRIP 
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RELE_T1 CONNECT NOC2_TRIP 

RELE_T9 CONNECT CBF1_CBFPACT 

RELE_T8 CONNECT CBF1_CBFPACT 

RELE_T10 CONNECT OV1_TRIP 

LED_START CONNECT OV1_START 

LED_TRIP LATCH OV1_TRIP 

LED_TRIP LATCH CBF1_CBFPACT 

LED_TRIP LATCH NOC1_TRIP 

Table 8.3 Snipping of exported setting file parameters with logic details

#Logic details 

#Gate pos x Gate pos y 

0 190 

0 490 

50 340 

100 410 

100 510 

110 660 

110 730 

140 40 

140 130 

150 210 

230 350 

240 710 
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9. Print configuration

9.1 Print configuration

You can print aqs configurations as PDF files with the Print menu.

Print active view prints the current view as a PDF. If more than one view of the .aqs file is needed, click Select views to
print and check the views you want printed.

The first selection shows the main menus. Check the appropriate box and click Print.

If you want to print a specific subsection of a menu, click on the black arrow next to the check box to expand the menu. The
image below (to the left) shows an example, where only the setting view of the I> (over-current) function's first stage is
printed. The image below (to the right) shows what the PDF looks like.
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10. Viewing disturbance recordings

10.1 Viewing disturbance recordings

Open the view in DEIF MVR USW by clicking Disturbance recorder on the main toolbar and then select Launch MVR USW.

You can open disturbance recordings in the Utility Software by clicking the Open folder button  or by going to File >
Open. The recordings are packed COMTRADE files.

A .zip file includes *.cfg and *.dat. MVR USW can open original packed .zip files and COMTRADE file, as both *.cfg and *.dat
are in the same directory.
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